Bug 358431 - Unable to Update
Unable to Update
Status: CLOSED DUPLICATE of bug 325901
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 11:31 EDT by kalash
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 20:02:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file (2.61 KB, application/octet-stream)
2007-10-30 11:31 EDT, kalash
no flags Details

  None (edit)
Description kalash 2007-10-30 11:31:57 EDT
Description of problem:
Unable to apply updates

Version-Release number of selected component (if applicable):
devel 7.92

How reproducible:
Click on Update Icon on top causes error dump

Steps to Reproduce:
1.Update says 266 updates available
2.Click View Updates/Apply Updates
3.
  
Actual results:
error
Component: pirut
Summary: TB19ba829d __init__.py:158:pirutCDHandler:NameError: global name
'DBusException' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
    main()
  File "/usr/sbin/pup", line 610, in main
    pup.run()
  File "/usr/sbin/pup", line 449, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 267, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 302, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 268, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 522, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 758, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 750, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 733, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 563, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative =
relative, text = text, copy_local = copy_local, url = url, mediaid =
self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 158, in
pirutCDHandler
    except DBusException, e:
NameError: global name 'DBusException' is not defined

Local variables in innermost frame:
cddevs:
dbus.Array([dbus.String(u'/org/freedesktop/Hal/devices/storage_model_BD_MLT_UJ_210S')],
signature=dbus.Signature('s'))
hal: <Interface <ProxyObject wrapping <dbus._dbus.SystemBus (system) at
0x12a26b0> :1.4 /org/freedesktop/Hal/Manager at 0x1320850> implementing
'org.freedesktop.Hal.Manager' at 0x13208d0>
name: Fedora 7.92
self: <__main__.PackageUpdater object at 0x103d8d0>
args: ()
umount: False
mediaid: 1191242166.874799
HalCD: <module 'pirut.HalCD' from
'/usr/lib/python2.5/site-packages/pirut/HalCD.pyc'>
dev: <pirut.HalCD.HALBlockDevice instance at 0x13248c0>
discnum: 1
kwargs: {'mediaid': '1191242166.874799', 'name': 'Fedora 7.92', 'url': None,
'text': <yum.yumRepo.YumRepository object at 0x130e1d0>, 'relative':
'repodata/repomd.xml', 'range': (None, None), 'checkfunc': (<bound method
YumRepository._checkRepoXML of <yum.yumRepo.YumRepository object at 0x130e1d0>>,
(), {}), 'copy_local': 1, 'discnum': 1, 'local': '//var/cacheComponent: pirut
Summary: TB19ba829d __init__.py:158:pirutCDHandler:NameError: global name
'DBusException' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
    main()
  File "/usr/sbin/pup", line 610, in main
    pup.run()
  File "/usr/sbin/pup", line 449, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 267, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 302, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 268, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 522, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 758, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 750, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 733, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 563, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative =
relative, text = text, copy_local = copy_local, url = url, mediaid =
self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 158, in
pirutCDHandler
    except DBusException, e:
NameError: global name 'DBusException' is not defined

Local variables in innermost frame:
cddevs:
dbus.Array([dbus.String(u'/org/freedesktop/Hal/devices/storage_model_BD_MLT_UJ_210S')],
signature=dbus.Signature('s'))
hal: <Interface <ProxyObject wrapping <dbus._dbus.SystemBus (system) at
0x12a26b0> :1.4 /org/freedesktop/Hal/Manager at 0x1320850> implementing
'org.freedesktop.Hal.Manager' at 0x13208d0>
name: Fedora 7.92
self: <__main__.PackageUpdater object at 0x103d8d0>
args: ()
umount: False
mediaid: 1191242166.874799
HalCD: <module 'pirut.HalCD' from
'/usr/lib/python2.5/site-packages/pirut/HalCD.pyc'>
dev: <pirut.HalCD.HALBlockDevice instance at 0x13248c0>
discnum: 1
kwargs: {'mediaid': '1191242166.874799', 'name': 'Fedora 7.92', 'url': None,
'text': <yum.yumRepo.YumRepository object at 0x130e1d0>, 'relative':
'repodata/repomd.xml', 'range': (None, None), 'checkfunc': (<bound method
YumRepository._checkRepoXML of <yum.yumRepo.YumRepository object at 0x130e1d0>>,
(), {}), 'copy_local': 1, 'discnum': 1, 'local':
'//var/cache/yum/InstallMedia/repomd.xml'}
found: False
cdudi: /org/freedesktop/Hal/devices/storage_model_BD_MLT_UJ_210S
/yum/InstallMedia/repomd.xml'}
found: False
cdudi: /org/freedesktop/Hal/devices/storage_model_BD_MLT_UJ_210S

Expected results:


Additional info:
Comment 1 kalash 2007-10-30 11:31:57 EDT
Created attachment 243591 [details]
dump file
Comment 2 Peter van Egdom 2007-11-14 14:06:45 EST
Thank you for the report. However this has been reported to the incorrect
component. Reassinging from "up2date" to "pirut". Feel free to report any
further bugs you find to our bug tracking system.
Comment 3 Jeremy Katz 2007-11-15 20:02:46 EST

*** This bug has been marked as a duplicate of 325901 ***

Note You need to log in before you can comment on or make changes to this bug.