This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 358511 - avc denial on nsf-utils-1.0.12-4.fc7
avc denial on nsf-utils-1.0.12-4.fc7
Status: CLOSED DUPLICATE of bug 358171
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 12:24 EDT by colinbrockway
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 07:29:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description colinbrockway 2007-10-30 12:24:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8

Description of problem:
Summary
    SELinux is preventing /sbin/rpc.statd (rpcd_t) "search" to sbin (bin_t).

Detailed Description
    SELinux denied access requested by /sbin/rpc.statd. It is not expected that
    this access is required by /sbin/rpc.statd and this access may signal an
    intrusion attempt. It is also possible that the specific version or
    configuration of the application is causing it to require additional access.

Allowing Access
    Sometimes labeling problems can cause SELinux denials.  You could try to
    restore the default system file context for sbin, restorecon -v sbin If this
    does not work, there is currently no automatic way to allow this access.
    Instead,  you can generate a local policy module to allow this access - see
    http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385 Or you can disable
    SELinux protection altogether. Disabling SELinux protection is not
    recommended. Please file a http://bugzilla.redhat.com/bugzilla/enter_bug.cgi
    against this package.

Additional Information        

Source Context                system_u:system_r:rpcd_t
Target Context                system_u:object_r:bin_t
Target Objects                sbin [ dir ]
Affected RPM Packages         nfs-utils-1.0.12-4.fc7
                              [application]filesystem-2.4.6-1.fc7 [target]
Policy RPM                    selinux-policy-2.6.4-8.fc7
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   plugins.catchall_file
Host Name                     unknown-00-0f-b0-68-d1-71.home
Platform                      Linux unknown-00-0f-b0-68-d1-71.home
                              2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT
                              2007 i686 i686
Alert Count                   1
First Seen                    Mon 03 Sep 2007 12:51:52 PM BST
Last Seen                     Mon 03 Sep 2007 12:51:52 PM BST

Line Numbers                  

Raw Audit Messages            

avc: denied { search } for comm="rpc.statd" dev=dm-0 egid=0 euid=0
exe="/sbin/rpc.statd" exit=-13 fsgid=0 fsuid=0 gid=0 items=0 name="sbin"
pid=7671 scontext=system_u:system_r:rpcd_t:s0 sgid=0
subj=system_u:system_r:rpcd_t:s0 suid=0 tclass=dir
tcontext=system_u:object_r:bin_t:s0 tty=(none) uid=0



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1.
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Steve Dickson 2007-11-01 07:29:11 EDT

*** This bug has been marked as a duplicate of 358171 ***

Note You need to log in before you can comment on or make changes to this bug.