Bug 358721 - Fn key in Macbook Pro does not work
Fn key in Macbook Pro does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 14:00 EDT by Robert Szalai
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.23.1-49.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 18:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Szalai 2007-10-30 14:00:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.8) Gecko/20071023 Fedora/2.0.0.8-1.fc8 Firefox/2.0.0.8

Description of problem:
The config option in the kernel is disabled.

[robbie@mbp ~]$ cat /boot/config-2.6.23.1-35.fc8 | grep POWERBOOK
# CONFIG_USB_HIDINPUT_POWERBOOK is not set

Please set this to =y. It was fixed once in F7, but somebody has removed this config option.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-37.fc8

How reproducible:
Always


Steps to Reproduce:
1. Try to use the pgDown, pgUp, Home keys with Fn.
You can try the F? keys for adjusting backlight speaker volume.
2. Notice that it does not work.
3. 

Actual Results:
I became sad, since I've already reported this problem in BUG 219968, and nothing has happened, even though it is a simple fix.

Expected Results:
Those keys should have behaved as on my desktop computer.

Additional info:
Comment 1 Chuck Ebbert 2007-10-30 21:27:58 EDT
(In reply to comment #0)
> I became sad, since I've already reported this problem in BUG 219968, and
nothing has happened, even though it is a simple fix.

Adding comments to bugs that were closed long ago won't do much good.
 
Looks like this is just needed in config-x86_64-generic:
CONFIG_USB_HIDINPUT_POWERBOOK=y

Comment 2 Robert Szalai 2007-10-30 22:30:05 EDT
Thanks for replying. Are you sure that other architectures are not affected? 
When I recompiled the kernel I've modified the arch independent config file to 
make it work. I could not find this option neither in i386 nor in x86_64.
Comment 3 Chuck Ebbert 2007-10-31 17:07:54 EDT
$ grep POWERBOOK config*
config-generic:# CONFIG_USB_HIDINPUT_POWERBOOK is not set
config-powerpc-generic:CONFIG_USB_HIDINPUT_POWERBOOK=y
config-x86-generic:CONFIG_USB_HIDINPUT_POWERBOOK=y
Comment 4 Chuck Ebbert 2007-10-31 19:57:36 EDT
This is fixed in Fedora 7 now, will be fixed in F8 with the first kernel update
after release.
Comment 5 Fedora Update System 2007-11-09 18:38:02 EST
kernel-2.6.23.1-49.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.