This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 35894 - Installing any package (one or more) generates
Installing any package (one or more) generates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 13:25 EDT by Tommy Reynolds
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:15:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tommy Reynolds 2001-04-13 13:25:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14smp i686)


After up2date loads and installs an RPM (whether new or an update), the
following lines appear via stderr and the GUI freezes:

root@dhcp-177(48)# up2date -a        
/var/spool/up2date/astyle-1.11.6-5.i386.rpm: md5 gpg OK
Traceback (innermost last):
File "/usr/share/rhn/up2date/gui.py", line 524, in doInstallation
up2date.installPackages(self.selectedPkgList, self.rpmCallback)
File "/usr/share/rhn/up2date/up2date.py", line 1204, in installPackages
remoteDelPackages(removedPackages)    
File "/usr/share/rhn/up2date/up2date.py", line 669, in remoteDelPackages
if type(pkg[0]) == type([]):
IndexError: list index out of range

The package gets installed ("rpm -q <package>" gives the usual
information).  I tried rebuilding the RPM database ("rpm --rebuilddb") but
up2date still gives this error.

Reproducible: Always
Steps to Reproduce:
1.  up2date (as either root or a normal user).
2.  pick one or more RPM's to be downloaded.
3.  watch the progress, keep pressing "NEXT" when prompted.
4.  observe error messages on stderr while GUI gives a mostly grey display.
	

Actual Results:  root@dhcp-177(48)# up2date -a        
/var/spool/up2date/astyle-1.11.6-5.i386.rpm: md5 gpg OK
Traceback (innermost last):
File "/usr/share/rhn/up2date/gui.py", line 524, in doInstallation
up2date.installPackages(self.selectedPkgList, self.rpmCallback)
File "/usr/share/rhn/up2date/up2date.py", line 1204, in installPackages
remoteDelPackages(removedPackages)    
File "/usr/share/rhn/up2date/up2date.py", line 669, in remoteDelPackages
if type(pkg[0]) == type([]):
IndexError: list index out of range
Comment 1 Preston Brown 2001-04-16 11:07:18 EDT
what version of up2date do you have installed?
 
rpm -q up2date
Comment 2 Adrian Likins 2004-04-05 16:15:29 EDT
closing, old (and long since fixed)

Note You need to log in before you can comment on or make changes to this bug.