Bug 35894 - Installing any package (one or more) generates
Summary: Installing any package (one or more) generates
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-13 17:25 UTC by Tommy Reynolds
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 20:15:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tommy Reynolds 2001-04-13 17:25:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14smp i686)


After up2date loads and installs an RPM (whether new or an update), the
following lines appear via stderr and the GUI freezes:

root@dhcp-177(48)# up2date -a        
/var/spool/up2date/astyle-1.11.6-5.i386.rpm: md5 gpg OK
Traceback (innermost last):
File "/usr/share/rhn/up2date/gui.py", line 524, in doInstallation
up2date.installPackages(self.selectedPkgList, self.rpmCallback)
File "/usr/share/rhn/up2date/up2date.py", line 1204, in installPackages
remoteDelPackages(removedPackages)    
File "/usr/share/rhn/up2date/up2date.py", line 669, in remoteDelPackages
if type(pkg[0]) == type([]):
IndexError: list index out of range

The package gets installed ("rpm -q <package>" gives the usual
information).  I tried rebuilding the RPM database ("rpm --rebuilddb") but
up2date still gives this error.

Reproducible: Always
Steps to Reproduce:
1.  up2date (as either root or a normal user).
2.  pick one or more RPM's to be downloaded.
3.  watch the progress, keep pressing "NEXT" when prompted.
4.  observe error messages on stderr while GUI gives a mostly grey display.
	

Actual Results:  root@dhcp-177(48)# up2date -a        
/var/spool/up2date/astyle-1.11.6-5.i386.rpm: md5 gpg OK
Traceback (innermost last):
File "/usr/share/rhn/up2date/gui.py", line 524, in doInstallation
up2date.installPackages(self.selectedPkgList, self.rpmCallback)
File "/usr/share/rhn/up2date/up2date.py", line 1204, in installPackages
remoteDelPackages(removedPackages)    
File "/usr/share/rhn/up2date/up2date.py", line 669, in remoteDelPackages
if type(pkg[0]) == type([]):
IndexError: list index out of range

Comment 1 Preston Brown 2001-04-16 15:07:18 UTC
what version of up2date do you have installed?
 
rpm -q up2date


Comment 2 Adrian Likins 2004-04-05 20:15:29 UTC
closing, old (and long since fixed)


Note You need to log in before you can comment on or make changes to this bug.