Bug 35898 - losetup fails when file is > 2G
Summary: losetup fails when file is > 2G
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-13 18:26 UTC by Paul Flinders
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 18:26:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Flinders 2001-04-13 18:26:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3-ac4 i686)


Even with a kernel with large file support it is not possible
to set up loop devices on files which are > 2G.

The problem is simply that it does not use O_LARGEFILE
when opening the file.

Reproducible: Always
Steps to Reproduce:
1. install a kernel with largefile support
2. dd if=/dev/zero of=file bs=1024 count=4194304
3. losetup /dev/loop0 file
	

Actual Results:  The message "file: File too large" is printed.

Comment 1 Bernhard Rosenkraenzer 2001-05-17 19:29:06 UTC
Fixed in 2.11b-5



Note You need to log in before you can comment on or make changes to this bug.