Bug 359011 - pirut and pup no longer work after latest upgrade
pirut and pup no longer work after latest upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 15:34 EDT by todd english
Modified: 2014-01-21 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 13:56:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description todd english 2007-10-30 15:34:49 EDT
Description of problem:


Version-Release number of selected component (if applicable):
pirut-1.3.9-1.fc7.src.rpm

How reproducible:
always

Steps to Reproduce:
1. Allow automatic update to happen
2. Launch pirut or pup
3. wait...
  
Actual results:
nothing happens. When launching pup, after a long time (10+ minutes) a dialog
will open that says "config error\r\n Unable to start due to a configuration
error". Under the Details box there is "None"

Expected results:
pup or pirut will launch

Additional info:
yum works.
Comment 1 Seth Vidal 2007-10-30 16:02:45 EDT
reassigning to pirut
Comment 2 Jeremy Katz 2007-10-30 16:17:40 EDT
Can you try the pirut from updates-testing
  yum --enablerepo=updates-testing update pirut
and see what you get?
Comment 3 todd english 2007-10-30 18:44:27 EDT
[root@darth-sidious ~]# yum --enablerepo=updates-testing update pirut
http://mirror.nuvio.com/pub/fedora/linux/releases/7/Everything/x86_64/os/repodata/repomd.xml:
[Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
fedora                    100% |=========================| 2.1 kB    00:00     
updates-testing           100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 171 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
emperor                   100% |=========================|  951 B    00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package pirut.noarch 0:1.3.23-1.fc7 set to be updated
--> Processing Dependency: python-iniparse for package: pirut
--> Running transaction check
---> Package python-iniparse.noarch 0:0.2.2-1.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 pirut                   noarch     1.3.23-1.fc7     updates-testing   326 k
Installing for dependencies:
 python-iniparse         noarch     0.2.2-1.fc7      updates            32 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 358 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): python-iniparse-0. 100% |=========================|  32 kB    00:00     
(2/2): pirut-1.3.23-1.fc7 100% |=========================| 326 kB    00:00     
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
Importing GPG key 0x30C9ECF8 "Fedora Project (Test Software)
<rawhide@redhat.com>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: python-iniparse              ######################### [1/3] 
  Updating  : pirut                        ######################### [2/3] 
  Cleanup   : pirut                        ######################### [3/3] 

Dependency Installed: python-iniparse.noarch 0:0.2.2-1.fc7
Updated: pirut.noarch 0:1.3.23-1.fc7
Complete!


After that when I run pirut I see the gui come up (an improvement) and then a
dialog comes up saying "Retrieving Software Information". The status thermometer
completely fills up and then pirut seems to hang; the thermometer is filled in
with blue and the mouse cursor remains in the "hourglass" state.

Comment 4 todd english 2007-10-31 00:31:09 EDT
Aditional info:
After waiting for an untold amount of time (longer than 5 minutes, possibly 20
minutes) there was a dialog that said:
Unable to retrieve software information.
Unable to retrieve software information. This could be caused by not having a
network connection available.
Details:
failure: repodata/comps-f7.xml from updates: [Errno 256] No more mirrors to try.
Comment 5 shrek-m 2007-10-31 05:49:56 EDT
# strace -opup-f7.strace pup
generates a 36MB file full with "no such file or directory"
eg.
--------
stat("/usr/lib/python2.5/site-packages/yum/urlgrabber", 0x7fffc4008020) = -1
ENOENT (No such file or directory)
open("/usr/lib/python2.5/site-packages/yum/urlgrabber.so", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/lib/python2.5/site-packages/yum/urlgrabbermodule.so", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/lib/python2.5/site-packages/yum/urlgrabber.py", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/lib/python2.5/site-packages/yum/urlgrabber.pyc", O_RDONLY) = -1
ENOENT (No such file or directory)
----/----


$ ls /usr/lib/python2.5/site-packages/yum/
callbacks.py   failover.pyc       packages.pyo      rpmtrans.py
callbacks.pyc  failover.pyo       parser.py         rpmtrans.pyc
callbacks.pyo  __init__.py        parser.pyc        rpmtrans.pyo
comps.py       __init__.pyc       parser.pyo        sqlitesack.py
comps.pyc      __init__.pyo       pgpmsg.py         sqlitesack.pyc
comps.pyo      logginglevels.py   pgpmsg.pyc        sqlitesack.pyo
config.py      logginglevels.pyc  pgpmsg.pyo        sqlutils.py
config.pyc     logginglevels.pyo  plugins.py        sqlutils.pyc
config.pyo     mdparser.py        plugins.pyc       sqlutils.pyo
constants.py   mdparser.pyc       plugins.pyo       transactioninfo.py
constants.pyc  mdparser.pyo       repoMDObject.py   transactioninfo.pyc
constants.pyo  misc.py            repoMDObject.pyc  transactioninfo.pyo
depsolve.py    misc.pyc           repoMDObject.pyo  update_md.py
depsolve.pyc   misc.pyo           repos.py          update_md.pyc
depsolve.pyo   packageSack.py     repos.pyc         update_md.pyo
Errors.py      packageSack.pyc    repos.pyo         yumRepo.py
Errors.pyc     packageSack.pyo    rpmsack.py        yumRepo.pyc
Errors.pyo     packages.py        rpmsack.pyc       yumRepo.pyo
failover.py    packages.pyc       rpmsack.pyo
Comment 6 shrek-m 2007-11-01 19:12:53 EDT
today it is ok, pup and pirut are working as expected.

Note You need to log in before you can comment on or make changes to this bug.