Bug 359041 - kmail: gpg backend no longer working with error: "An error occurred while fetching the keys from the backend: General error"
kmail: gpg backend no longer working with error: "An error occurred while fet...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 15:56 EDT by Douglas E. Warner
Modified: 2008-01-02 10:16 EST (History)
1 user (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 10:16:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas E. Warner 2007-10-30 15:56:35 EDT
Description of problem:
When trying to configure KMail's gpg key settings, the following error dialog 
is shown:

An error occurred while fetching the keys from the backend:
General error

Additionally, the messages that I send that are "signed" don't appear to be 
signed with my key, despite the pinhelper popping up and asking for my 
passphrase.


Version-Release number of selected component (if applicable):
$ rpm -q kdepim
kdepim-3.5.7-10.svn20070926.ent.fc7


How reproducible:
always.


Steps to Reproduce:
1. In kmail, Settings->Configure KMail
2. Identities tab, modify a menu
3. if you have keys selected for this identity, you will get an error right 
away; otherwise, go to the cryptography tab and select 'change' for one of the 
keys.
  
Actual results:
The error described above.

Expected results:
Messages are signed correctly.

Additional info:
None.
Comment 1 Rex Dieter 2007-11-29 21:58:11 EST
Can you try out this test build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26172
Comment 2 Douglas E. Warner 2007-11-30 10:58:04 EST
Since upgrading to F8 I haven't experienced this bug.  I occasionally have 
problems where the gpg-agent isn't found, but typically restarting kmail fixes 
this.
Comment 3 Lukáš Tinkl 2008-01-02 10:16:00 EST
Fixed in F8 according to reporter

Note You need to log in before you can comment on or make changes to this bug.