Bug 35919 - rmmod of bttv in gnome crashes RH7.1 (seawolf)
rmmod of bttv in gnome crashes RH7.1 (seawolf)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 19:47 EDT by greg hosler
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 11:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg hosler 2001-04-13 19:47:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14smp i686)


when logging into a gnome desktop, there is a probe (might be done by X)
that
insmods or modprobes bttv. If bttv is rmmod'ed in gnome, everything totally
freezes.
KDE is OK, if not logged in to desktop (i.e. gdm running, and you switch to
console) that's OK as well.


Reproducible: Always
Steps to Reproduce:
1. login to gnome desktop
2.wait for the 10 minute "rmmod -as" - system will hang at that point.
3.or, manually rmmod bttv - again system will hang
	

Actual Results:  bttv mod removes (according to the syslog), but system
freezes.

Expected Results:  system should not freeze

box is SMP, running seawolf. video card is a "Win TV"

contact me and I'll e-mail you a syslog. or anything else that is wanted.
Comment 1 Arenas Belon, Carlo Marcelo 2001-04-21 00:10:05 EDT
seems like it is no really related to the bttv module unloaded as i've been
getting the same problem
while an es1370 is unloaded or the cdrom module is unloaded.

but it seems related to GNOME and having a bttv card.
Comment 2 greg hosler 2001-04-29 06:39:24 EDT
I've tracked down some additional information.

1) this bug is desktop independent (also happens under KDE, also happens if you
    do not login to a desktop)

2) this crash is due to the presence of the dolby sound chip on the
    bt878 chip. For example, the Win-TV Theatre has a dpl 3518.c sound chip
which is
    improperly detected as a tda9840 sound chip. When bttv is rmmod'd it will
unregister
    itself from the tda9840 module, and the kernel will panic. It seems that the
tda9840 module
    causes spurious interrupts that the kernel doesn't properly handle.

Note You need to log in before you can comment on or make changes to this bug.