Bug 359201 - cancel of application exit fails
cancel of application exit fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 407461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 17:09 EDT by Andrew Gilmore
Modified: 2007-12-06 15:55 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.3.26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 10:37:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Gilmore 2007-10-30 17:09:33 EDT
Description of problem:
Pirut warns the user when packages are selected but haven't been installed, and
the user attempts to exit.
However, if the user clicks on "Don't quit" the application closes the main
window and the question is asked again. If the user selects "Don't quit" again,
pirut never completely exits, but any windows are not visible.

"Quit anyway" works correctly.

Version-Release number of selected component (if applicable):
pirut-1.3.25-2.fc8
Comment 1 Jeremy Katz 2007-10-30 17:35:08 EDT
Fixed in git, will be in 1.3.26 (which won't be until post-F8)
Comment 2 Fedora Update System 2007-11-20 12:49:57 EST
pirut-1.3.26-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'
Comment 3 Andrew Gilmore 2007-11-26 10:37:43 EST
Confirmed fixed in 1.3.26
Comment 4 Fedora Update System 2007-11-28 20:33:54 EST
pirut-1.3.27-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'
Comment 5 Jeremy Katz 2007-12-04 16:45:28 EST
*** Bug 407461 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2007-12-06 15:45:21 EST
pirut-1.3.28-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2007-12-06 15:55:00 EST
pirut-1.3.28-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.