This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 359331 - GFS: on a shared root its impossible to run gfs_tool lockdump on the root fs
GFS: on a shared root its impossible to run gfs_tool lockdump on the root fs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-utils (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On: 350571
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 18:14 EDT by Robert Peterson
Modified: 2010-01-11 22:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 16:23:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Peterson 2007-10-30 18:14:45 EDT
+++ This bug was initially created as a clone of Bug #350571 +++
Crosswriting from RHEL4 to RHEL5.

On a shared root fs you cant get a lockdump by doing a gfs_tool lockdump / 
because /proc/mounts looks like this

rootfs on / type rootfs (rw)
none on /dev type tmpfs (rw)
/dev/vg_zhlr421_sr/lv_sharedroot on / type gfs (rw,noatime,nodiratime)


This patch resolves the problem.

-- Additional comment from jwhiter@redhat.com on 2007-10-24 11:10 EST --
Created an attachment (id=236261)
patch to fix the problem.


-- Additional comment from rpeterso@redhat.com on 2007-10-30 17:26 EST --
I'll take it.


-- Additional comment from rpeterso@redhat.com on 2007-10-30 17:47 EST --
Deferring to 4.7 as per discussion with Josef.


-- Additional comment from rkenna@redhat.com on 2007-10-30 17:51 EST --
Same problem on RHEL5 with gfs{,2}_tool?
Comment 1 Robert Peterson 2008-06-12 16:23:12 EDT
I believe this is now fixed by virtue of bug #431951 and bug #431952
which are co-requisites.  I still haven't heard back on the RHEL4 parent
bug #350571 so I'm just going to assume it's fixed and close this one.
If we need to do a code change later, we'll open up another bug record
at that time.

Note You need to log in before you can comment on or make changes to this bug.