Bug 35964 - Xprt does'nt have a config file
Xprt does'nt have a config file
Status: CLOSED DUPLICATE of bug 35593
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-15 11:54 EDT by LENHOF
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 05:56:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LENHOF 2001-04-15 11:54:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9 i686; en-US; 0.8)
Gecko/20010217


I wanted to test the impression with OpenOffice but there's no config file
which come with Xprt

Reproducible: Always
Steps to Reproduce:
1.Just try printing with OpenOffice
2.
3.
Comment 1 Mike A. Harris 2001-06-01 01:22:45 EDT
Nothing uses Xprt on a wide scale yet, and from what I understand, it is
broken.  The apps that do use it (OpenOffice, Mozilla) are in deep
development, and not finalized.  Until there are stable apps that use
Xprint, there is no use supporting it.
Comment 2 Mike A. Harris 2001-06-01 01:43:26 EDT

*** This bug has been marked as a duplicate of 35593 ***
Comment 3 Need Real Name 2001-06-01 05:56:52 EDT
> Nothing uses Xprt on a wide scale yet,

What about CDE 2.x ?

> and from what I understand, it is
> broken.  

Only in X11R6.4. Starting with X11R6.5.1 it's useable, X11R6.6 added some more
improvements and there will be future developements (like adding PPD support and
so on...).
Xfree86 CVS recently imported X11R6.5.1 sources incl. Xprint... it should be
working now...

> The apps that do use it (OpenOffice, Mozilla) are in deep
> development, and not finalized.  Until there are stable apps that use
> Xprint, there is no use supporting it.

Mozilla's Xprint module is nearly finished, only three bugs left (excluding the
print dialog (GUI))...
Comment 4 Mike A. Harris 2001-06-05 01:58:20 EDT
This bug has been marked duplicate, any followups should be done on the other
bug report.  In answer to your points:

CDE is not supported.  It would not IMHO make much sense for us to spend
time supporting all of a sudden.  People wanting a supported desktop 
environment should use KDE or GNOME.  CDE is no compelling reason to 
spend engineering resources on Xprt.

XFree86 4.1.0 is merged with 6.5.1 yes.  Neither Mozilla nor OpenOffice are
finalized working applications, they are developmental applications.  When
they are finalized, and Xprt support is considered a critical thing then
we can justify working on adding support for it.  "should be working" is not
an argument for me to include it either.  Developers working on Mozilla or
OpenOffice can likely rebuild X for themselves, but I simply do not consider
Xprint viable right now for us to support.  I look forward to doing so when
it is _proven_ to work, and work well with stable applications.

We are just beginning our development cycle.  If during this cycle Xprint
appears that it is stable and wouldn't be a support burden, and there are
serious stable non-beta apps out there relying on it, then we can consider
enabling it.  Until then, developer time is better spent elsewhere.

Note You need to log in before you can comment on or make changes to this bug.