Bug 36064 - snmp cannot load shared library librpm.so.0, missing fdio symbol
snmp cannot load shared library librpm.so.0, missing fdio symbol
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-16 13:59 EDT by Warren Mansur
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-16 13:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Mansur 2001-04-16 13:59:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


I installed the stock RedHat 7.0 for Intel Linux from a retail box.  Then, 
I download the latest version of snmp (4.2.1-1).  When I run anything to 
do with snmp, such as /etc/init.d/snmpd start, or snmpwalk, then I get the 
following exact error message: 

error while loading shared libraries: /usr/lib/librpm.so.0: undefined 
symbol: fdio

The current version of rpm was 4.0-4.  As described in bug number 24246, I 
upgraded to 4.0.2-7x.  Issuing rpm -qa | grep rpm gives the following 
results on my system now:

rpm-devel-4.0.2-7x
gnorpm-0.9-27
rpm-build-4.0.2-7x
rpm-python-4.0-4
rpm-4.0.2-7x

Even after upgrading, I still get the same error message.



Reproducible: Always
Steps to Reproduce:
1. Install RedHat Linux 7.0 from the retail box
2. Install the latest version of snmp (4.2.1-1)
3. Run /etc/init.d/snmpd start or snmpwalk
	

Actual Results:  Got the error message described on the descrition section

Expected Results:  snmpd should have worked properly.
Comment 1 Bill Nottingham 2001-04-16 16:29:34 EDT
That's most likely an error with whomever packaged that version of
ucd-snmp; the latest we've shipped for 7.0 is 4.1.2-8.

Note You need to log in before you can comment on or make changes to this bug.