Bug 360681 - Remove use of IP address as basis for SCSI reservation keys
Remove use of IP address as basis for SCSI reservation keys
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
ia64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
: ZStream
Depends On: 248715
Blocks: 420581
  Show dependency treegraph
 
Reported: 2007-10-31 14:13 EDT by Ryan O'Hara
Modified: 2009-04-16 15:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0801
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:16:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ryan O'Hara 2007-11-08 12:06:54 EST
Changing the title of this bug to more accurately reflect the problem.
Comment 2 Ryan O'Hara 2007-11-08 12:07:19 EST
Fixed. Completely removed use of IP address as basis for SCSI reservation keys,
since this was causing problems. Instead, the SCSI reservation keys are now
based on the cluster ID and node ID. Specifically, the high 16-bits of the key
will be hex value of the cluster ID and the low 16-bits will be hex value of the
node ID.

Both the scsi_reserve init script and fence_scsi agent were modified for this
change.

Please note that this fix break compatability with older versions of fence_scsi,
since the new code will not recognize the old key format.
Comment 3 Chris Feist 2007-12-11 16:00:57 EST
Setting acks so bug can be cloned for 4.6.z stream.
Comment 8 Chris Feist 2007-12-20 11:43:56 EST
Changing to fence.
Comment 11 errata-xmlrpc 2008-07-25 15:16:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0801.html

Note You need to log in before you can comment on or make changes to this bug.