Bug 361111 - ipv6 enabled squid
ipv6 enabled squid
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
http://devel.squid-cache.org/ipv6/
:
: 468811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 19:15 EDT by shrek-m
Modified: 2016-07-26 19:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 04:15:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2007-10-31 19:15:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8

Description of problem:
squid seems not to be ipv6 enabled.
apache and firefox can handle ipv6 without squid.
$ firefox http://[2001::101]  is ok.

via squid i get the squid-error "invalid url"

----acces.log----
1193871049.369      0 127.0.0.1 TCP_DENIED/400 1514 GET http://[2001::101]/ - NONE/- text/html
1193871049.594      0 127.0.0.1 TCP_DENIED/400 1536 GET http://[2001::101]/favicon.ico - NONE/- text/html
----/----

Version-Release number of selected component (if applicable):
squid-2.6.STABLE16-2.fc8

How reproducible:
Always


Steps to Reproduce:
1. firefox http://[ipv6] via squid

Actual Results:


Expected Results:


Additional info:
# ping6 2001::101
PING 2001::101(2001::101) 56 data bytes
64 bytes from 2001::101: icmp_seq=1 ttl=64 time=0.035 ms


# lsof -i :80
COMMAND   PID   USER   FD   TYPE DEVICE SIZE NODE NAME
httpd   10916   root    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10918 apache    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10919 apache    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10920 apache    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10921 apache    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10922 apache    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10923 apache    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10924 apache    4u  IPv6 401867       TCP *:http (LISTEN)
httpd   10925 apache    4u  IPv6 401867       TCP *:http (LISTEN)
Comment 1 shrek-m 2007-12-17 14:52:50 EST
squid 3.0 stable1 is released :)

http://www.squid-cache.org/Versions/
Stable Versions:
Version
3.0
First PRE Release Date
  Aug 15, 2003
First STABLE release Date
  Dec 13, 2007
Latest Release
  STABLE1
Latest Release Date
  Dec 13, 2007
Comment 2 Martin Nagy 2008-03-03 09:07:18 EST
I think it might be a better idea to wait for 3.1
Comment 3 Martin Nagy 2008-04-08 04:15:51 EDT
According to http://wiki.squid-cache.org/RoadMap/Squid3 IPv6 will be available
in squid-3.1 (and already are in HEAD). Let's wait for it. Closing with the
resolution UPSTREAM.
Comment 4 Martin Nagy 2008-10-28 03:17:53 EDT
*** Bug 468811 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.