Bug 36137 - weird BUGZILLA report with INSTALLER
weird BUGZILLA report with INSTALLER
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-16 22:45 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-16 23:07:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-16 22:45:50 EDT
I installed RedHat 7.0 on my IBM Thinkpad iSeries laptop without
difficulty three months.  Then I removed it.  Now I tried to put it
back again and hit a snag.  I tried both a graphical install and a text
one, and both times it told me to file this report.  Attached below are
the two outputs, which were slightly different, so I thought it prudent
to supply both.  Do you have any idea why this bug should show up now,
and didn't on previous installs on the same machine?  Any help would be
appreciated, since I can't install/use RedHat Linux because the installer
just reboots (after showing this bugzilla message).

------------------

Graphical install attempt:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.GuiFstab instance at 844b5d0>
mntPoint: /mnt/sysimage
selected: [ImageMagick, LPRng, MAKEDEV, Mesa, Mesa-devel, ORBit, SDL, 
SysVinit, XFree86, XFree86-75dpi-fonts, XFree86-devel, XFree86-libs, 
XFree86-tools, XFree86-twm, XFree86-xdm, XFree86-xfs, Xaw3d, Xaw3d-devel, 
Xconfigurator, anacron, apmd, arpwatch, ash, at, audiofile, aumix, 
authconfig, autoconf, automake, awesfx, basesystem, bash, bc, bdflush, 
bind-utils, binutils, bison, byacc, bzip2, bzip2-devel, cdecl, cdparanoia, 
chkconfig, chkfontpath, compat-egcs, compat-egcs-c++, compat-glibc, compat-
libstdc++, console-tools, control-panel, cpio, cpp, cproto, cracklib, 
cracklib-dicts, crontabs, ctags, cvs, cyrus-sasl, db1, db2, db3, dev, 
dev86, dhcpcd, diffstat, diffutils, docbook, dosfstools, dump, e2fsprogs, 
ed, eject, esound, file, filesystem, fileutils, findutils, finger, flex, 
fortune-mod, freetype, ftp, gawk, gcc, gcc-c++, gcc-java, gd, gd-devel, 
gdb, gdbm, gdbm-devel, gettext, ghostscript, ghostscript-fonts, gimp, 
glib, glib-devel, glibc, glibc-devel, gmp, gnome-audio, gnome-libs, gnome-
linuxconf, gnupg, gphoto, gpm, gpm-devel, grep, groff, groff-perl, gtk+, 
gtk+-devel, gv, gzip, hdparm, imlib, indent, indexhtml, info, initscripts, 
ipchains, iproute, iptables, iputils, irda-utils, isapnptools, isdn-
config, isdn4k-utils, jed, jed-common, jed-xjed, jikes, kaffe, kbdconfig, 
kdebase, kdegraphics, kdelibs, kdelibs-devel, kdemultimedia, kdenetwork, 
kdesupport, kdesupport-devel, kdeutils, kdevelop, kernel, kernel-headers, 
kernel-pcmcia-cs, kernel-utils, kernelcfg, kgcc, kpppload, krb5-devel, 
krb5-libs, kudzu, kudzu-devel, less, libgcj, libgcj-devel, libglade, 
libjpeg, libjpeg-devel, libpng, libpng-devel, libstdc++, libstdc++-devel, 
libtermcap, libtermcap-devel, libtiff, libtiff-devel, libtool, libtool-
libs, libungif, libungif-devel, libxml, lilo, linuxconf, linuxconf-devel, 
logrotate, losetup, lsof, ltrace, m4, mailcap, mailx, make, man, man-
pages, memprof, mikmod, mingetty, mkbootdisk, mkinitrd, mkisofs, mktemp, 
mkxauth, modemtool, modutils, mount, mouseconfig, mpage, mpg123, mtools, 
multimedia, ncftp, ncompress, ncurses, ncurses-devel, ncurses4, net-tools, 
netcfg, netpbm, netpbm-devel, netpbm-progs, netscape-common, netscape-
communicator, newt, newt-devel, nfs-utils, njamd, ntsysv, openjade, 
openldap, openssh, openssh-askpass, openssh-clients, openssl, openssl-
devel, pam, passwd, patch, pciutils, pciutils-devel, perl, pidentd, 
playmidi, plugger, pmake, pnm2ppa, popt, portmap, ppp, printtool, 
procmail, procps, psmisc, pump, pwdb, pygnome, pygtk, pygtk-libglade, 
python, python-devel, python-xmlrpc, pythonlib, qt, qt-devel, qt1x, qt1x-
devel, quota, raidtools, rcs, rdate, readline, readline-devel, redhat-
logos, redhat-release, rhn_register, rhn_register-gnome, rhs-printfilters, 
rmt, rootfiles, rp-pppoe, rpm, rpm-build, rpm-devel, rpm-python, rsh, 
rusers, rwho, rxvt, samba-client, samba-common, sane, sash, screen, sed, 
sendmail, setserial, setup, setuptool, sgml-common, sgml-tools, sh-utils, 
shadow-utils, shapecfg, sharutils, slang, slang-devel, slocate, smpeg, 
sndconfig, sox, stat, statserial, strace, stylesheets, switchdesk, 
sysklogd, talk, tar, tcl, tclx, tcp_wrappers, tcsh, telnet, termcap, tetex-
fonts, tetex-xdvi, texinfo, textutils, time, timeconfig, timetool, tix, 
tk, tkinter, tksysv, tmpwatch, traceroute, unzip, up2date, up2date-gnome, 
urw-fonts, usermode, utempter, util-linux, vim-common, vim-minimal, vixie-
cron, which, whois, wireless-tools, words, wvdial, xinitrc, xisdnload, 
xloadimage, xmms, xmorph, xpaint, xpdf, xsane, xscreensaver, xsri, xxgdb, 
yp-tools, ypbind, zip, zlib, zlib-devel]
self: <image.CdromInstallMethod instance at 8447cb8>
p: gcc-java
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

------------------

Textual install attempt:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.NewtFstabinstance at 8209f58>
mntPoint: /mnt/sysimage
selected: [ImageMagick, LPRng, MAKEDEV, Mesa, Mesa-devel, ORBit, SDL, 
SysVinit, XFree86, XFree86-75dpi-fonts, XFree86-devel, XFree86-libs, 
XFree86-tools, XFree86-twm, XFree86-xdm, XFree86-xfs, Xaw3d, Xaw3d-devel, 
Xconfigurator, anacron, apmd, arpwatch, ash, aspell, at, audiofile, aumix, 
authconfig, autoconf, automake, autorun, awesfx, basesystem, bash, bc, 
bdflush, bind-utils, binutils, bison, byacc, bzip2, bzip2-devel, cdda2wav, 
cdecl, cdp, cdparanoia, cdrecord, chkconfig, chkfontpath, compat-egcs, 
compat-egcs-c++, compat-glibc, compat-libstdc++, console-tools, control-
panel, cpio, cpp, cproto, cracklib, cracklib-dicts, crontabs, ctags, cvs, 
cyrus-sasl, db1, db2, db3, dev, dev86, dhcpcd, diffstat, diffutils, dip, 
docbook, dosfstools, dump, e2fsprogs, ed, eject, elm, esound, exmh, 
expect, fetchmail, file, filesystem, fileutils, findutils, finger, flex, 
fortune-mod, freetype, ftp, gawk, gcc, gcc-c++, gcc-g77, gcc-java, gd, gd-
devel, gdb, gdbm, gdbm-devel, gettext, ghostscript, ghostscript-fonts, 
gimp, glib, glib-devel, glibc, glibc-devel, gmp, gnome-audio, gnome-libs, 
gnome-linuxconf, gnupg, gphoto, gpm, gpm-devel, grep, groff, groff-perl, 
gtk+, gtk+-devel, gv, gzip, hdparm, ical, imlib, indent, indexhtml, inews, 
info, initscripts, ipchains, iproute, iptables, iputils, irda-utils, 
isapnptools, isdn-config, isdn4k-utils, jikes, kaffe, kbdconfig, kdebase, 
kdegraphics, kdelibs, kdelibs-devel, kdemultimedia, kdenetwork, 
kdesupport, kdesupport-devel, kdeutils, kdevelop, kernel, kernel-headers, 
kernel-pcmcia-cs, kernel-utils, kernelcfg, kgcc, kpppload, krb5-devel, 
krb5-libs, kudzu, kudzu-devel, less, libgcj, libgcj-devel, libglade, 
libjpeg, libjpeg-devel, libpng, libpng-devel, libstdc++, libstdc++-devel, 
libtermcap, libtermcap-devel, libtiff, libtiff-devel, libtool, libtool-
libs, libungif, libungif-devel, libxml, lilo, links, linuxconf, linuxconf-
devel, logrotate, losetup, lrzsz, lsof, ltrace, lynx, m4, mailcap, mailx, 
make, man, man-pages, memprof, metamail, mikmod, mingetty, minicom, 
mkbootdisk, mkinitrd, mkisofs, mktemp, mkxauth, modemtool, modutils, 
mount, mouseconfig, mpage, mpg123, mtools, multimedia, mutt, ncftp, 
ncompress, ncurses, ncurses-devel, ncurses4, net-tools, netcfg, netpbm, 
netpbm-devel, netpbm-progs, netscape-common, netscape-communicator, newt, 
newt-devel, nfs-utils, njamd, nmh, ntsysv, openjade, openldap, openssh, 
openssh-askpass, openssh-clients, openssl, openssl-devel, pam, passwd, 
patch, pciutils, pciutils-devel, perl, pidentd, pilot-link, pilot-link-
devel, pine, playmidi, playmidi-X11, plugger, pmake, pnm2ppa, popt, 
portmap, ppp, printtool, procmail, procps, psmisc, pspell, pump, pwdb, 
pygnome, pygtk, pygtk-libglade, python, python-devel, python-xmlrpc, 
pythonlib, qt, qt-devel, qt1x, qt1x-devel, quota, raidtools, rcs, rdate, 
readline, readline-devel, redhat-logos, redhat-release, rhn_register, 
rhn_register-gnome, rhs-printfilters, rmt, rootfiles, rp-pppoe, rpm, rpm-
build, rpm-devel, rpm-python, rsh, rsync, rusers, rwho, rxvt, samba-
client, samba-common, sane, sash, screen, sed, sendmail, setserial, setup, 
setuptool, sgml-common, sgml-tools, sh-utils, shadow-utils, shapecfg, 
sharutils, slang, slang-devel, slocate, slrn, smpeg, sndconfig, sox, stat, 
statserial, strace, stunnel, stylesheets, switchdesk, switchdesk-kde, 
sysklogd, talk, tar, tcl, tclx, tcp_wrappers, tcsh, telnet, termcap, tetex-
fonts, tetex-xdvi, texinfo, textutils, time, timeconfig, timetool, tin, 
tix, tk, tkinter, tksysv, tmpwatch, traceroute, trn, unzip, up2date, 
up2date-gnome, urlview, urw-fonts, usermode, utempter, util-linux, vim-
common, vim-minimal, vixie-cron, which, whois, wireless-tools, words, 
wvdial, xcdroast, xinitrc, xisdnload, xloadimage, xmailbox, xmms, xmorph, 
xpaint, xpdf, xrn, xsane, xscreensaver, xsri, xxgdb, yp-tools, ypbind, 
zip, zlib, zlib-devel]
self: <image.CdromInstallMethod instance at 828c0d8>
p: gcc-java
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Brent Fox 2001-04-16 23:07:46 EDT
I can't explain why the bug would appear three months later...that's kind of
strange.  However, this bug has been reported many times. Have a look at bug
#19928 for more information.  Are you trying to install to a FAT partition this
time and maybe you didn't last time?  We just released 7.1 today, and this bug
has been fixed in 7.1, so if you have the bandwidth, I'd recommend downloading
it.  From looking at bug #19928, the bug reporter says that the anaconda updates
disk that we released for 7.0 fixed the problem.  It can be found at
http://www.redhat.com/support/errata/RHBA-2000-084.html
Since this bug is fixed in 7.1, I'm resolving the bug as 'Current Release"

Note You need to log in before you can comment on or make changes to this bug.