Bug 361861 - sos traceback.format_exc() not available in RHEL4 (python < 2.4)
sos traceback.format_exc() not available in RHEL4 (python < 2.4)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sos (Show other bugs)
4.5
All Linux
urgent Severity low
: rc
: ---
Assigned To: Adam Stokes
: ZStream
Depends On:
Blocks: 469727 469728
  Show dependency treegraph
 
Reported: 2007-11-01 10:22 EDT by Navid Sheikhol-Eslami
Modified: 2010-10-22 15:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Navid Sheikhol-Eslami 2007-11-01 10:22:28 EDT
Description of problem:

When an exception occurs, this is trapped and handled behind the console via a
try.. except statement.

The traceback.format_exc() function used to do this is new in version 2.4, which
means that it is unavailable in RHEL4 - which means that if an exception occurs,
it will be printed to the foreground and not in the logs.

Exception in thread general-thread:               ][00:16/06:28]
        Traceback (most recent call last):
          File "/usr/lib64/python2.3/threading.py", line 436, in __bootstrap
            self.run()
          File "/usr/lib64/python2.3/threading.py", line 416, in run
            self.__target(*self.__args, **self.__kwargs)
          File "/usr/lib/python2.3/site-packages/sos/plugintools.py", line 482,
in copyStuff
            self.soslog.log(logging.VERBOSE, traceback.format_exc())
        AttributeError: 'module' object has no attribute 'format_exc'
Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Navid Sheikhol-Eslami 2007-11-01 10:44:35 EDT
This is merely a cosmetic bug, the problem is already fixed in upstream repository.

-- Navid
Comment 13 errata-xmlrpc 2009-05-18 16:23:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0994.html

Note You need to log in before you can comment on or make changes to this bug.