Bug 362511 - HTS should run suspend every test run
Summary: HTS should run suspend every test run
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-01 20:19 UTC by Greg Nichols
Modified: 2008-02-15 15:24 UTC (History)
0 users

Fixed In Version: RHBA-2008-0034
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 15:24:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0034 normal SHIPPED_LIVE hts bug fix and enhancement update 2008-02-15 15:24:44 UTC

Description Greg Nichols 2007-11-01 20:19:18 UTC
Description of problem:

HTS should run a shortened version of the suspend test on all battery-equipped
systems before running other tests.

Comment 1 Greg Nichols 2007-11-27 15:04:38 UTC
Fixed R12

Comment 3 Satyabrata Maitra 2007-12-14 10:38:07 UTC
Hi Greg

May I know if this test can be performed remotely via ssh or not? 
In errata, what suggested regarding this bug is...

".....Run the "hts certify --test core" and verify that both
info and suspend are also run........."

What is suspend test? May you pls explain me a bit! 
And if I can find any "steps to follow" guidance from your side, I will be
grateful! Please inform these.

Comment 4 Greg Nichols 2007-12-17 15:34:32 UTC
The suspend test verifies that the system can be suspended to memory and disk,
the successfully resumed.  This test can not be preformed remotely, since the
tester must resume the system by pressing the power button.

Comment 5 Satyabrata Maitra 2007-12-18 09:09:25 UTC
Hi Greg

I got 3 questions when I attempted to test it.... as follows :-

1. So, this test must be run on battery-equipped systems like laptop, notebook
etc with physical access to the system, right? Or the system-under-test may be
any desktop too? Please inform.

2. When exactly to resume the system, pressing the power button during testing?
May I get complete test steps to follow? Please inform.

3. How to verify that both info and suspend are also run? Please inform.

Satya

Comment 6 Greg Nichols 2007-12-18 14:18:05 UTC
1. The suspend test is only run on battery-equipped systems.

2. The power button should be pushed each time suspend has completed.

3. hts print should show all the tests that ran.

Comment 7 Satyabrata Maitra 2007-12-26 09:52:19 UTC
Greg
Ok, but I do not have any battery-equipped system available with me for testing.
So, can not proceed with this bug testing. 
May I request you to anybody having this facility please, so that he/she can
test and comment on this bug and ensure bug fix? Then I can proceed with this
errata to push it to server.
Satya

Comment 8 Rob Landry 2008-01-02 20:54:42 UTC
I've tested this today on an IBM T30 with hts-5.1-18.el5.noarch.rpm, RHEL5 beta
+ a bad HD :(

Tested using "hts certify --test audio"; which proceeded to ask to shutdown,
respond with "yes", it warns 5 seconds to a suspend, pressing power to resume it
asks if it suspended, respon with yes, hts proceeded onto the audio test
followed by the info test running.  Afterwards "hts print" reports suspend,
info, & audio all as run with a result of pass.

Unfortunately due to the bad HD I'm unable to attach a results package...

ide: failed opcode was: unknown
ide0: rest: success
hda: lost interrupt
hda: lost interrupt
had: lost interrupt

...if more data is required it seems a laptop should not be that rare an item.

Comment 9 Lawrence Lim 2008-01-09 02:34:11 UTC
This has been confirmed fixed by rlandry in Comment #8.

Comment 12 errata-xmlrpc 2008-02-15 15:24:46 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0034.html



Note You need to log in before you can comment on or make changes to this bug.