Bug 362591 - Provisioning can never complete if earliest date is set in the past.
Provisioning can never complete if earliest date is set in the past.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 248627
  Show dependency treegraph
 
Reported: 2007-11-01 16:54 EDT by Justin Sherrill
Modified: 2008-04-02 20:19 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:19:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2007-11-01 16:54:22 EDT
The provisioning feature will not complete if the earliest date is set more than
4 hours in the past.  The reason behind this is that when computing the tiny URL
expire date the formula "earliest date + 4 hours" is used.  This is fine when it
is in the future, but for past dates, this leads to tiny urls that expire before
they are created.

Stumbled over this when working on another bug.
Comment 1 Justin Sherrill 2007-11-02 13:45:20 EDT
fixed in rev 133468.
Comment 2 Justin Sherrill 2007-11-09 17:30:58 EST
moving on_qa
Comment 3 Steve Salevan 2007-11-27 17:03:02 EST
I tried setting a date in the past, and this works.  As a result, I'm moving
this to VERIFIED.
Comment 4 Devan Goodwin 2008-03-26 13:25:45 EDT
The web UI seems to just convert a date in the past to the current time and
schedule the event for then, regardless I think this is expected. 

Release pending.
Comment 5 Brandon Perkins 2008-04-02 20:19:52 EDT
5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.