Bug 362741 - Pirut and Yum Are Not Consistent
Pirut and Yum Are Not Consistent
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: beta
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-01 18:17 EDT by Steve Siano
Modified: 2013-04-12 15:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 16:48:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Siano 2007-11-01 18:17:09 EDT
Description of problem:
Pirut and Yum are not consistent.

GROUPS
1.  Pirut lists the following groups which are not listed by yum grouplist:

   Base
   Dialup Networking Support
   Legacy Software Support

as well as the 58 Support groups in the Languages "super group".

2.  Pirut lists Java in the Red Hat Enterprise Linux Extras and Base System 
super groups.  It should probably only be in one.

3.  Pirut lists GNOME Software Development in the Desktop Environments and 
Development super groups.  It should probably be broken up, just like with KDE, 
which has the KDE (K Desktop Environment) and KDE Software Development groups.

PACKAGES
4.  The package lists are also not consistent.  For example, with the Web 
Server group, Yum lists two packages that are not listed by Pirut:

   crypto-utils   (Default)
   httpd-suexec   (Optional)

5.  Pirut does not list the Mandatory packages.  For example, with the Web 
Server group, Yum lists

   httpd          (Mandatory)

6.  Yum has three types - Mandatory, Default, and Optional.  Pirut only has 
Optional, which includes both the Yum Default and Optional packages.

Version-Release number of selected component (if applicable):
RHEL 5 Client
Linux <hostname> 2.6.18-8.1.15.el5 #1 SMP Thu Oct 4 04:06:39 EDT 2007 x86_64 
x86_64 x86_64 GNU/Linux

yum 3.0.1
yum-rhn-plugin-0.4.3-2.el5

How reproducible:
Always.

Steps to Reproduce:
1.  Run Yum and save the output in text files.
2.  Run Pirut (Package Manager), Main Menu -> Add/Remove Software.
3.  Compare the group and package lists.

Actual results:
See above.

Expected results:
See above.  I would expect Pirut and Yum to be perfectly consistent since Pirut 
is a graphical frontend to Yum.

Additional info:
Comment 2 RHEL Product and Program Management 2008-07-21 19:08:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 James Antill 2010-09-20 16:48:48 EDT
 Short summary: In general, I don't think differences are a problem here. A graphical UI probably shouldn't ever be identical to a cmd line UI.

 Longer response:

> 1.  Pirut lists the following groups which are not listed by yum grouplist:

 Use: yum grouplist hidden
 Not sure why pirut lists the hidden groups by default, but I doubt we want to change it at this point.

> 2 & 3

 These are comps. problems, not pirut ones ... it's just displaying the data it's given.

> 4, 5 & 6

 This is intentional from both bits of code. yum lists default+optional+mandatory ... and when in groupinstall triggers off of group_package_types (default: mandatory+default).

 Pirut uses groups as a way to browse for extra packages ... so just lists optional+default.
 It's not perfect, but changing it at this point would be a pretty bad idea.

Note You need to log in before you can comment on or make changes to this bug.