Bug 36298 - Can't ssh2 to OpenSSH_2.3.0p1 on Solaris
Can't ssh2 to OpenSSH_2.3.0p1 on Solaris
Status: CLOSED DUPLICATE of bug 34797
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 12:54 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 12:54:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-17 12:54:35 EDT
When I try to ssh to a Solaris machine running OpenSSH_2.3.0p1, I get a
"Bad packet length" error:  (host name and IP address removed)

$ ssh -v -v -v HOSTNAME
OpenSSH_2.5.2p2, SSH protocols 1.5/2.0, OpenSSL 0x0090600f
debug1: Seeding random number generator
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: ssh_connect: getuid 500 geteuid 0 anon 1
debug1: Connecting to HOSTNAME [X.X.X.X] port 22.
debug1: Connection established.
debug1: unknown identity file /home/wtpooh/.ssh/identity
debug1: identity file /home/wtpooh/.ssh/identity type -1
debug1: unknown ideopenssl-0.9.6-3ntity file /home/wtpooh/.ssh/id_rsa
debug1: identity file /home/wtpooh/.ssh/id_rsa type -1
debug1: unknown identity file /home/wtpooh/.ssh/id_dsa
debug1: identity file /home/wtpooh/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_2.3.0p1
debug1: match: OpenSSH_2.3.0p1 pat ^OpenSSH_2\.3\.0
Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_2.5.2p2
debug2: Original cipher proposal:
aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael128-cbc,rijndael192-cbc,rijndael256-cbc,rijndael-cbc@lysator.liu.se
debug2: Compat cipher proposal: 3des-cbc,blowfish-cbc,cast128-cbc,arcfour
debug1: send KEXINIT
debug1: done
debug1: wait KEXINIT
debug1: got kexinit:
diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
debug1: got kexinit: ssh-dss
debug1: got kexinit:
3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes128-cbc,aes192-cbc,aes256-cbc,rijndael128-cbc,rijndael192-cbc,rijndael256-cbc,rijndael-cbc@lysator.liu.se
debug1: got kexinit:
3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes128-cbc,aes192-cbc,aes256-cbc,rijndael128-cbc,rijndael192-cbc,rijndael256-cbc,rijndael-cbc@lysator.liu.se
debug1: got kexinit: hmac-sha1,hmac-md5,hmac-ripemd160@openssh.com
debug1: got kexinit: hmac-sha1,hmac-md5,hmac-ripemd160@openssh.com
debug1: got kexinit: none,zlib
debug1: got kexinit: none,zlib
debug1: got kexinit: 
debug1: got kexinit: 
debug1: first kex follow: 0 
debug1: reserved: 0 
debug1: done
debug2: mac_init: found hmac-md5
debug1: kex: server->client 3des-cbc hmac-md5 none
debug2: mac_init: found hmac-md5
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: Sending SSH2_MSG_KEX_DH_GEX_REQUEST.
debug1: Wait SSH2_MSG_KEX_DH_GEX_GROUP.
debug1: Got SSH2_MSG_KEX_DH_GEX_GROUP.
debug1: dh_gen_key: priv key bits set: 201/384
debug1: bits set: 500/1024
debug1: Sending SSH2_MSG_KEX_DH_GEX_INIT.
debug1: Wait SSH2_MSG_KEX_DH_GEX_REPLY.
debug1: Got SSH2_MSG_KEXDH_REPLY.
debug1: Host 'HOSTNAME' is known and matches the DSA host key.
debug1: Found key in /home/wtpooh/.ssh/known_hosts2:1
debug1: bits set: 486/1024
debug1: len 55 datafellows 4224
debug1: ssh_dss_verify: signature correct
debug1: Wait SSH2_MSG_NEWKEYS.
debug1: GOT SSH2_MSG_NEWKEYS.
debug1: send SSH2_MSG_NEWKEYS.
debug1: done: send SSH2_MSG_NEWKEYS.
debug1: done: KEX2.
debug1: send SSH2_MSG_SERVICE_REQUEST
Received disconnect from 171.66.121.166: 2: Bad packet length -1223311497.
debug1: Calling cleanup 0x8061610(0x0)
$ 

I am using RH7.1, openssl-0.9.6-3, openssh-2.5.2p2-5,
openssh-clients-2.5.2p2-5.

I am able to connect using 'ssh -1 HOSTNAME`, and I can connect using ssh2
from my other machine, which has these rpms installed:

openssl-0.9.5a-14
openssh-2.1.1p4-1
openssh-clients-2.1.1p4-1
Comment 1 Pekka Savola 2001-04-18 13:42:02 EDT

*** This bug has been marked as a duplicate of 34797 ***

Note You need to log in before you can comment on or make changes to this bug.