Bug 36318 - Cron running "minutely" jobs multiple times a minute
Cron running "minutely" jobs multiple times a minute
Status: CLOSED DUPLICATE of bug 29868
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 14:39 EDT by Jason M. Sullivan
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 14:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason M. Sullivan 2001-04-17 14:39:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; AIX 4.3)


I did an upgrade from 6.1 to 7.0, and then applied updates to get to the
level vixie-cron-3.0.1-61.  Root has a crontab that runs jobs every
minute.  Now it looks like I have jobs running multiple times a minute
(even the messages file records this).  Since these programs update several
files, this causes some confusion.  It looks like I have both vixie-cron
and anacron installed, but I only see one "crond" when I do a "ps".



Reproducible: Sometimes
Steps to Reproduce:
1. Install new cron.
2. Edit crontab file to have entries that run every minute.
3. View the messages file.
4. Cry.
	

Installed cron-related packages...

vixie-cron-3.0.1-61
anacron-2.3-9
crontabs-1.8-1

Crontab for the root user...
# DO NOT EDIT THIS FILE - edit the master and reinstall.
# (/tmp/crontab.29344 installed on Thu Mar 15 22:15:39 2001)
# (Cron version -- $Id: crontab.c,v 2.13 1994/01/17 03:20:37 vixie Exp $)
* * * * * /home/httpd/other-scripts/update-pic     > /dev/null 2>&1
* * * * * /home/httpd/other-scripts/check-real     > /dev/null 2>&1

Selected output from the /var/log/messages file...
Apr 17 14:27:00 united CROND[13868]: (root) CMD
(/home/httpd/other-scripts/check-real     > /dev/null 2>&1) 
Apr 17 14:27:00 united CROND[13869]: (root) CMD
(/home/httpd/other-scripts/update-pic     > /dev/null 2>&1) 
Apr 17 14:27:59 united CROND[13921]: (root) CMD
(/home/httpd/other-scripts/check-real     > /dev/null 2>&1) 
Apr 17 14:27:59 united CROND[13922]: (root) CMD
(/home/httpd/other-scripts/update-pic     > /dev/null 2>&1) 
Apr 17 14:28:00 united CROND[13941]: (root) CMD
(/home/httpd/other-scripts/check-real     > /dev/null 2>&1) 
Apr 17 14:28:01 united CROND[13942]: (root) CMD
(/home/httpd/other-scripts/update-pic     > /dev/null 2>&1)
Comment 1 Bill Nottingham 2001-04-17 21:51:53 EDT

*** This bug has been marked as a duplicate of 29868 ***

Note You need to log in before you can comment on or make changes to this bug.