Bug 36357 - up2date cannot determine RedHat version
Summary: up2date cannot determine RedHat version
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-17 20:04 UTC by Loren Peace
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 20:04:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Loren Peace 2001-04-17 20:04:45 UTC
After using up2date to update up2date to version 2.5.3-0.6.x it fails 
with the following message.

There was a fatal RPM error.  The message was:
Couldn't determine what version of Red Hat Linux you are running.

I have checked the up2date.py file and believe the problem is on line 
234 where it checks the RPM database for a package that provides 
redhat-release and while redhat-release has the file 
/etc/redhat-release i believe this looks for virtual providers and since 
nothing provides redhat-release, as confimed by "rpm -q 
--whatprovides redhat-release", up2date can't find the redhat-release 
rpm and thus can't find the RedHat version.

There is an interum solution to people experiencing this problem, 
edit /etc/sysconfig/rhn/up2date and set versionOverride to your 
RedHat version until a new up2date fixes the problem.

Comment 1 Jay Turner 2001-04-17 20:20:55 UTC
This is a side-effect of the upgrade to rpm-4.0.2 . . . to resolve the issue,
just run 'rpm --rebuilddb' as root and things will start working again.

Comment 2 Jeff 2003-04-08 14:52:57 UTC
I had the same problem on my redhat 7.3 box:
when using rhn_register, the program crashed and
I got the "Couldn't determine version" error message.
The rhn_register version is 2.7.21-7.x.3
and the rpm version is 4.0.4-7x.18
I tried the rpm --rebuilddb command but it did not work ( I have not
upgraded anything yet )
I edited /etc/sysconfig/rhn/up2date file but it still does
not work.
I removed many rpms to get a light system, maybe the problem
comes from that ?


Note You need to log in before you can comment on or make changes to this bug.