Bug 363571 - TAHI--DHCPv6--When having DHCPv6 tests, TN could not get expected Relay Reply Message (Advertise)
TAHI--DHCPv6--When having DHCPv6 tests, TN could not get expected Relay Reply...
Status: CLOSED DUPLICATE of bug 365521
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-11-02 05:57 EDT by Zhiyong Wu
Modified: 2008-05-08 01:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 15:46:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-11-02 05:57:03 EDT
Description of problem:

  When having dhcpv6 tests in the server mode,we found that TN could not get 

expected Relay Reply Message (Advertise) in some scenarios.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   TN could not get expected Relay Reply Message (Advertise)

Expected results:

   TN should get expected Relay Reply Message (Advertise)

Additional info:
  
   please refer to 

http://focus.brisbane.redhat.com/~zwu/dhcp_server/20071101/DHCPv6_Self_Test_P2_1_0_7_server/rfc3315/index.html

   (1) 12	Part B : Relay Agent/Server Message Format

   (2) 24	Relay Message Option Format

   (3) 25	Interface ID Option Format (Advanced)

   (4) 30	Part E : Relay-Reply message with Advertise message (w/o Interface-id
Option)

   (5) 31	Part F : Relay-Reply message with Advertise message (w/ Interface-id
Option) (Advanced)

   (6) 33	Part B : Reply-Reply message with Reply message (w/o Interface-id Option)

   (7) 34	Part C : Reply-Reply message with Reply message (w/ Interface-id Option)

   (8) 35	Part A : Relay-Reply message transmission

   (9) 36	Part B : Relay-Reply message transmission through the same Relay agents
Comment 3 Zhiyong Wu 2008-01-15 23:46:32 EST
yes, it is tested with (1) dhcpv6-1.0.4-1.el5.i386.rpm, (2)
dhcpv6-client-1.0.4-1.el5.i386.rpm (3) libdhcp6client-1.0.4-1.el5.i386.rpm)

For more information, pls refer to 

http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071225/DHCPv6_Self_Test_P2_1_0_8_server/rfc3315/index.html
Comment 4 David Cantrell 2008-01-17 18:38:21 EST
I don't know if I can get this one working for 5.2.  I would prefer to postpone
it to 5.3 unless someone else has a patch.  I have dhcpv6-1.0.8 in the tree now,
so it's worth testing with that.
Comment 5 Ken Reilly 2008-02-07 10:56:03 EST
Testing should proceed as note in Comment #4. Since this will not be resolved in
the 5.2 beta candidate I have reset the exception, rhel-5.2.0, devel_ack and
qa_ack flags to '?'. That said, this BZ will be re-evaluated as an exception for
5.2 along with any other unresolved bugs and/or feature requests as part of a
IVP6DoD compliance program review (which will be coordinated by Linda Wang)
after 5.2 is released to Public Beta.  
Comment 6 Lawrence Lim 2008-02-07 19:52:39 EST
zwu will be away till Fri, 15 Feb due to CNY celebration. I will try to do a run
with the Test Suite with the latest tree before that.
Comment 7 Zhiyong Wu 2008-02-20 22:32:06 EST
the test case still FAIL when testing rhel5.2 with dhcpv6-1.0.10,

For more detail, pls refer to 

http://focus.brisbane.redhat.com/~zwu/RHEL5.2-Server-20080212.0/20080220/DHCPv6_Self_Test_P2_1_0_8_server_1.0.10/rfc3315/index.html
Comment 8 Denise Dumas 2008-02-27 11:40:37 EST
In order to debug this problem, we need the test case for RHEL 5.2 with an exact
reproducer, including output with verbose debugging messages from the DHCPV6
software.  One way to do this would be to extract the commands that TAHI runs.
The man pages for dhcp6s, dhcp6r, and dhcp6c all show how to generate verbose
debug messages. 
Comment 9 David Cantrell 2008-03-11 15:46:16 EDT

*** This bug has been marked as a duplicate of 365521 ***

Note You need to log in before you can comment on or make changes to this bug.