Bug 363671 - nxsetup script fails
Summary: nxsetup script fails
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: freenx   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
high
low
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-02 12:08 UTC by Frank Büttner
Modified: 2007-12-29 00:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 00:17:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Büttner 2007-11-02 12:08:19 UTC
Description of problem:
The nxsetup script fails.

Version-Release number of selected component (if applicable):
freenx-0.7.0-1.fc6

How reproducible:


Steps to Reproduce:
1. cd /usr/share/doc/freenx-0.7.0
2. run ./nxsetup
  
Actual results:
After answer the question about the key, the script fails with:
which: no nxloadconfig in
(/usr/share/doc/freenx-0.7.0:/usr/lib/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/java/jre1.5.0_07/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
./nxsetup: line 130: .: filename argument required
.: usage: . filename [arguments]
Setting up  ...mkdir: missing operand
Try `mkdir --help' for more information.



Expected results:
getting freenx to work

Comment 1 Gwyn Ciesla 2007-11-02 12:12:51 UTC
It was my experience that you don't need to run nxsetup to get freenx working. 
Basically install, set up the config file, restart sshd, import the key to your
client, and you're in.

Comment 2 Frank Büttner 2007-11-02 12:27:57 UTC
Hm, but in the doc directory there are no doc how to setup the config files.

Comment 3 Axel Thimm 2007-11-29 17:14:56 UTC
nxsetup is for installing from the sources, e.g. it would conflict with the
files from the rpm. If something from nxsetup is missing in the packages we
should try to add it if possible.


Comment 4 Axel Thimm 2007-11-29 17:39:05 UTC
Frank, could you list what configuration nxsetup would perform for you that the
current packages don't? Note that rpm does nto have an interactive mode by
design, so no site specific configuration that requires interaction with the
user can be done on a package level.

Comment 5 Frank Büttner 2007-11-29 18:04:31 UTC
As an workaround I have installed the rpm packages from http://www.nomachine.com.
This works, but it have an total different config file structure. Because I need
an fast solution for it. When there are better documentation how to config the
freenx package than I can try it again. An simple yum install freenx are to
less, because not nxclient can connect.

Comment 6 Axel Thimm 2007-12-29 00:17:36 UTC
Well, this is not a bug, there is no open source GUI to travel you through the
config file setup yet, nxsetup also just does some basic setup.


Note You need to log in before you can comment on or make changes to this bug.