Bug 363861 - Evolution Save-as removes file name
Evolution Save-as removes file name
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 10:19 EDT by Marc Wiriadisastra
Modified: 2008-01-15 16:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 16:44:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Wiriadisastra 2007-11-02 10:19:57 EDT
Description of problem:
When you try to save a program in a different directory the name of the original
file gets removed and you have to re-enter it.

Version-Release number of selected component (if applicable):
evolution-2.12.1-3.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Receive an email with an attachment
2 [details]. Select Save-as
3. switch directories
  
Actual results:
The original file name gets removed and you have to re-enter it.

Expected results:
It would maintain the original file name and if you wanted to rename it you
would have to manually rename it.
Comment 1 Matthew Barnes 2007-11-02 11:25:00 EDT
Hmm, this sounds more like a GTK+ issue.

I can't seem to reproduce it for myself.  If I switch folders while saving an
attachment the base file name remains unchanged.

I'm using:

   evolution-2.21.1-2.fc9
   gtk2-2.12.1-5.fc8

But I don't think there's been any changes related to this between Evolution
2.12 and 2.21.

Can you please provide the output of "rpm -q gtk2"?
Comment 2 Marc Wiriadisastra 2007-11-02 12:16:02 EDT
gtk2-2.12.1-5.fc8 is the result.
Comment 3 Milan Crha 2007-11-02 12:46:01 EDT
I've same, and it's not Evolution issue at all, it's a gtk+ issue, because I can
do the same in gedit, for example. Though, it is very hard to reproduce it
consistently, for me. How do you choose your directory? It erased the filename
when choosing directory from bookmarks, but not every time. Also, I use my own
bookmark there.
Comment 4 Marc Wiriadisastra 2007-11-02 13:56:27 EDT
My double clicking on a folder.
Comment 5 Matthew Barnes 2007-11-06 15:45:22 EST
I can reproduce this behavior using Evolution, GEdit, and gThumb.

I could not reproduce it using Epiphany or Gnumeric.

Might have something to do with the way the suggested name is set in the
GtkFileChooserDialog.  Evolution does gtk_file_chooser_set_current_folder_uri()
followed by gtk_file_chooser_set_current_name().

Kickin' this over to gtk2 for now.
Comment 6 Zing 2007-11-12 19:23:35 EST
I can reproduce in seamonkey and gedit.  The reproduction recipe is very subtle
for me, meaning it seems to work sometimes and in certain circumstances.  I can
make it happen most consistently by clicking on a Places bookmark that is
_above_ the directory the filechooser wants to save in.

This is on F8 - gtk2-2.12.1-5.fc8.x86_64.

Related Upstream Bug:
Bug 419737 – File save dialog delets filename when changing directory
http://bugzilla.gnome.org/show_bug.cgi?id=419737
Comment 7 Marc Wiriadisastra 2008-01-15 16:44:08 EST
This bug can be closed it seems to be working and I notice that this bug is
still open.

Comment 8 Matthew Barnes 2008-01-15 16:48:52 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.