Bug 364151 - Python errors with some songs
Python errors with some songs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sonata (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Michał Bentkowski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 12:11 EDT by Reindl Harald
Modified: 2008-01-07 15:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 15:01:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2007-11-02 12:11:14 EDT
"sonata" seems to have problems with some songs
Will mean if they played it die away or will not start
If you change to another one with "mpc next" on the server the remote-client
works again....

Looks like a small fix for me but i can not program in python :-(

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/sonata.py", line 1380, in iterate
    self.handle_change_song()
  File "/usr/lib/python2.5/site-packages/sonata.py", line 2693, in
handle_change_song
    self.get_new_artist_for_album_name()
  File "/usr/lib/python2.5/site-packages/sonata.py", line 2672, in
get_new_artist_for_album_name
    self.set_artist_for_album_name()
  File "/usr/lib/python2.5/site-packages/sonata.py", line 4076, in
set_artist_for_album_name
    songs = self.browse_search_album(self.songinfo.album)
  File "/usr/lib/python2.5/site-packages/sonata.py", line 2087, in
browse_search_album
    list.sort(key=lambda x: int(self.sanitize_discnum(getattr(x, 'disc', ''),
False, 0) + self.sanitize_tracknum(getattr(x, 'track', '0'), False, 2)))
  File "/usr/lib/python2.5/site-packages/sonata.py", line 2087, in <lambda>
    list.sort(key=lambda x: int(self.sanitize_discnum(getattr(x, 'disc', ''),
False, 0) + self.sanitize_tracknum(getattr(x, 'track', '0'), False, 2)))
ValueError: invalid literal for int() with base 10: ''
Comment 1 Michał Bentkowski 2007-11-02 12:21:24 EDT
It should be rather reported to sonata's author.
However, new sonata 1.3 was released recently.
Please download a new version from here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=22917 
and check if the problem still exists.

BTW. The new sonata isn't pushed to repo as yet, because I still have to wait 
for python-ZSI to be put into repo...
Comment 2 Reindl Harald 2007-11-03 09:51:55 EDT
Yes, the new package solves this
Running a song what makes this troubles, updating sonata and after update it
starts without troubles
Comment 3 Reindl Harald 2007-11-22 12:58:54 EST
Why the upgrade is not published?
After upgrade to fedora 8 the same problem, and also 
a older version installed :-(
Comment 4 Michał Bentkowski 2007-11-22 15:49:23 EST
(In reply to comment #3)
> Why the upgrade is not published?
> After upgrade to fedora 8 the same problem, and also 
> a older version installed :-(
(comment #1)
> BTW. The new sonata isn't pushed to repo as yet, because I still have to wait 
> for python-ZSI to be put into repo...
> 

Comment 5 Reindl Harald 2007-11-22 16:18:38 EST
Without python-ZSI you get no lyrics, with the old version the application is
simply UNUSEABLE because it dys away not only by playing some somng, it dies
away by playing most songs
Comment 6 Michał Bentkowski 2008-01-07 12:17:33 EST
Now python-ZSI is in repo, sonata in testing.
Type:
  yum --enablerepo=updates-testing update sonata

to check whether it's all working.
Comment 7 Reindl Harald 2008-01-07 12:27:07 EST
yes, installed yesterday from koji and all looks fine
Comment 8 Michał Bentkowski 2008-01-07 15:01:49 EST
That's fine. All I can do now is to apologize for waiting such a long time
and close the bug.

Note You need to log in before you can comment on or make changes to this bug.