Bug 364531 - Product Names Not Being Preserved When A Channel Is Cloned
Product Names Not Being Preserved When A Channel Is Cloned
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Shannon Hughes
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 15:30 EDT by Devan Goodwin
Modified: 2007-11-02 15:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 15:48:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2007-11-02 15:30:15 EDT
Description of problem:

rhnChannel.product_name_id not being copied when a channel is cloned.

Version-Release number of selected component (if applicable):

Latest satellite devel builds.

How reproducible:

Always.


Steps to Reproduce:
1. Clone a channel.
2. Check rhnChannel.product_name_id for old and new channel.
  
Actual results:

New channel does not get the product name id of the old channel.

Expected results:

New channel should preserve the product name id.

Additional info:

This column is brand new and part of the EUS + child channel preservation work.
Correcting this will allow us to preserve cloned child channels.
Comment 1 Devan Goodwin 2007-11-02 15:48:20 EDT
Arg sorry about this. Had a fix that I thought was causing an infinite loop,
turns out the clone operation just needed time to run. Fix seems to be working
fine. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.