Bug 364951 - firstboot doesn't start if network connection fails
firstboot doesn't start if network connection fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 21:45 EDT by Max Kanat-Alexander
Modified: 2008-04-22 10:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 10:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mkanat: fedora_requires_release_note?


Attachments (Terms of Use)

  None (edit)
Description Max Kanat-Alexander 2007-11-02 21:45:09 EDT
I installed the 2007-10-24 rawhide in a KVM, and when it first booted, DHCP
failed (I forgot to fix the iptables on the host VM to allow the VM outbound
access).

Firstboot didn't start.

I fixed the problem with iptables on the host, restarted the VM, and firstboot
started.
Comment 1 Eric Paris 2007-11-07 13:02:05 EST
Happens in F8 if you just don't plug in a network cable or set ONBOOT=no for all
of the interfaces...
Comment 2 Max Kanat-Alexander 2007-11-07 17:06:21 EST
I'm betting this is going to have to be added to the release notes post-release.
Comment 3 Paul W. Frields 2007-11-08 07:51:44 EST
I think the common bugs page might be a better place for this:

http://fedoraproject.org/wiki/Bugs/F8Common

Feel free to edit that page directly to note the problem.  By the time we press
this to release notes and get it translated -- around 30 days from release is
the next planned update for relnotes -- it may be fixed in a package update. 
Obviously we can't do anything about the Gold ISOs at this point.
Comment 4 Andy Hudson 2007-11-10 10:58:56 EST
I'm seeing this behaviour too - my router seems to have given up the ghost on a
couple of ports so IP addresses weren't being doled out. Methinks this will
probably hit quite a few people!

There's no chance that this could be incorporated into an official update spin?
Comment 5 Andy Hudson 2007-11-10 13:02:41 EST
Further to this, I just installed Fedora 8 using the Live GNOME CD on a Dell
Latitude D620. I had network connectivity under the live environment, and could
browse the internet. Once the installation finished I rebooted into the
installed environment - no firstboot. Logged in as root to find that I had
network connectivity (could browse the internet). Checked my services at the
command line  to see that NetworkManager was enabled in Runlevels 2,3,4, & 5,
but NetworkManagerDispatcher was not enabled at all.

I disabled NetworkManager using chkconfig --levels 2345 NetworkManager stop and
rebooted. Hey presto, straight into firstboot.

 
Comment 6 Rui Matos 2007-11-10 14:27:41 EST
This seems to be some kind of race condition between the rhgb X server and the
GDM one triggered by the use of NetworkManager.

On one of those failed firstboots if you change to a vt and login as root you
can see a log on /tmp which basically says that gtk wasn't able to open the
$DISPLAY. 

I mean no offense to the rhgb developers but rhgb seems to be extremely fragile
to these kind of races. Hopefully on Fedora 9 with the new kernel graphics mode
setting all this hackery can just go away.
Comment 7 Chris Lumens 2007-11-12 11:34:32 EST
Please try again with rhgb-0.17.7-3.fc9 when it is pushed, as this version backs
out a patch regarding the handling of the loopback interface.  If that version
fixes this problem, we can go ahead and close this bug report out.
Comment 8 Rui Matos 2007-11-20 10:26:41 EST
(In reply to comment #7)
> Please try again with rhgb-0.17.7-3.fc9 when it is pushed, as this version backs
> out a patch regarding the handling of the loopback interface.  If that version
> fixes this problem, we can go ahead and close this bug report out.

That one doesn't fix it. Actually, the Fedora 8 live CD already has
rhgb-0.17.7-3.fc8.
Comment 9 Chris Lumens 2008-03-14 10:56:38 EDT
Is this any better in F9 Alpha?
Comment 10 Jerry Amundson 2008-03-28 16:01:42 EDT
No better with F9 Alpha. I'll download F9 Beta and try it.
Comment 11 Chris Lumens 2008-04-15 08:59:34 EDT
I am unable to reproduce this with networking disabled under rawhide.
Comment 12 Rui Matos 2008-04-22 10:05:35 EDT
Yup, this seems to work in F9 Preview.

Note You need to log in before you can comment on or make changes to this bug.