Bug 36498 - laptop hangs when resume occurs while plugged in
laptop hangs when resume occurs while plugged in
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 10:46 EDT by Yaron Minsky
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 20:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yaron Minsky 2001-04-18 10:46:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.8.1)
Gecko/20010327


My laptop (Gateway Solo 2500) hangs being reawakened when it is plugged in
to the power.  This did not occur with RH7.0.  When the freezup happens,
the mini-LCD panel shows that disk access is occuring, though I don't hear it.
Interestingly, if the laptop is not plugged in to the power, everything
works fine

Another thing worth noting is that the behavior of the power management is
quite different in general since I upgraded to 7.1.  In particular, I can
now put the laptop to sleep while in XWindows with no ill effects.

Reproducible: Always
Steps to Reproduce:
1. Put laptop to sleep
2. Plug it in
3. Hit the resume button
Comment 1 Arjan van de Ven 2001-04-18 10:55:46 EDT
Can you boot with the lilo-commandline option "ide=nodma" and see if that fixes
it?

This sounds like a bios issue; maybe the IDE state isn't preserved in some
cases.
Comment 2 Yaron Minsky 2001-04-18 11:10:59 EDT
I tried using the ide=nodma option (from the text-mode boot).  No improvement. 
Note that this problem started immediatly after I upgraded from 7.0 to 7.1, so
if it is a BIOS problem, it's one that was uncovered by the upgrade.  Also, I'm
running the latest BIOS for the machine (10.12), although I suppose that doesn't
mean the BIOS aren't buggy.
Comment 3 Arjan van de Ven 2001-04-26 09:54:46 EDT
Do you happen to have a eepro100 networkcard ?

Note You need to log in before you can comment on or make changes to this bug.