Bug 36502 - Installer problem with lilo.conf
Summary: Installer problem with lilo.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-18 15:44 UTC by Michael Schwendt
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 18:53:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lilo.conf.rpmsave (649 bytes, text/plain)
2001-04-18 15:45 UTC, Michael Schwendt
no flags Details

Description Michael Schwendt 2001-04-18 15:44:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686; Nav)


At the end of an upgrade from RHL 7.0 to RHL 7.1:

    An error occured while installing
    the bootloader.

    We HIGHLY recommend ... <snip>

    Fatal: Duplicate label "dos"

    <snip>

I remember I got asked for extra kernel parameters (I entered "mem=128M"
only) and whether I'd want to allow booting from my single DOS partition. I
answered "yes" and did not enter anything else. Got above error message,
but booting went fine without any errors and --
surprise! -- still with my beloved 2.2.19 kernel.

Investigation has revealed that a new LILO had not been written and the
Installer had ignored my "default=Linux" and had replaced it with
"default=dos".

It also ignored my 2.2.19 kernel entry (good luck!):

  image=/boot/vmlinuz-2.2.19
  label=Linux
  read-only
  root=/dev/hda7

and updated the 2.4.0 kernel test entry from:

  image=/boot/vmlinuz-2.4.0-0.43.5
  label=k24
  read-only
  root=/dev/hda7
  initrd=/boot/initrd-2.4.0-0.43.5.img

to:

  image=/boot/vmlinuz-2.4.2-2
  label=dos
  read-only
  root=/dev/hda7
  append="128M"

lilo.conf.rpmsave will be attached.


Reproducible: Didn't try

Expected Results:  I did expect Installer to upgrade a Linux kernel image
entry in lilo.conf and either boot the "default" entry or let me select a
new default.

If a kernel upgrade is mandatory, Installer could create an additional
entry in lilo.conf and make it the default regardless of any other entries.
If a kernel upgrade is optional, Installer could add a new kernel entry and
ask the user whether to make it the default.

Comment 1 Michael Schwendt 2001-04-18 15:45:41 UTC
Created attachment 15644 [details]
lilo.conf.rpmsave

Comment 2 Joe Krahn 2001-04-19 22:35:55 UTC
I had a similar problem upgrading RH7 to RH7.1.
It is a case sensitivity problem. The installer
added lable=linux but left in my label=Linux,
which lilo sees as being the same label.
In the above case, the user had label=DOS
and the installer added label=dos.

It looks like it the mangling above may be due to some
parts of the installer's lilo.conf editor being
case sensitive while others are not.

Comment 3 Matt Wilson 2001-07-19 18:53:05 UTC
moving to bootloader guy


Comment 4 Jeremy Katz 2001-07-19 21:50:09 UTC
Code that checks labels in the lilo.conf changed to be non case-sensitive in our
current tree.


Note You need to log in before you can comment on or make changes to this bug.