Bug 365031 - yum confused about provides
yum confused about provides
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-03 02:31 EDT by Ignacio Vazquez-Abrams
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 23:24:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from yum -d9 (4.23 KB, text/plain)
2007-11-03 02:31 EDT, Ignacio Vazquez-Abrams
no flags Details
Output from yum -d9 with fedorakmod plugin (4.33 KB, text/plain)
2007-11-09 03:50 EST, Ignacio Vazquez-Abrams
no flags Details

  None (edit)
Description Ignacio Vazquez-Abrams 2007-11-03 02:31:27 EDT
yum-(none):3.2.7-1.fc7.noarch

yum seems to be ignoring kernel packages when calculating provides. Or perhaps
it's removing them inappropriately.
Comment 1 Ignacio Vazquez-Abrams 2007-11-03 02:31:27 EDT
Created attachment 247221 [details]
Output from yum -d9
Comment 2 Tim Lauridsen 2007-11-03 03:20:33 EDT
Try to install the 'yum-fedorakmod' plugin, i you want the kmod-* updating to
work right.

Comment 3 Ignacio Vazquez-Abrams 2007-11-09 03:50:22 EST
Created attachment 252451 [details]
Output from yum -d9 with fedorakmod plugin

No dice.
Comment 4 Ignacio Vazquez-Abrams 2007-11-11 23:24:36 EST
Never mind. I had installed a kmod built in a way that didn't conform with the
kmod guidelines. It's still strange to see the effect it had on depsolving, but
I won't push for a fix.

Note You need to log in before you can comment on or make changes to this bug.