Bug 365191 - KDE sound problem
KDE sound problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-03 10:07 EDT by Sergei LITVINENKO
Modified: 2007-12-03 13:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 13:20:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei LITVINENKO 2007-11-03 10:07:35 EDT
Description of problem:
KDE sound system init fail.

If I understand right, arts is configured to use pulse audio, but KDE do not
provide/load necessary components. As result, aRts can not initialize playback
and KDE is mute.

Version-Release number of selected component (if applicable):

arts-1.5.8-4.fc8
kdebase-libs-3.5.8-5.fc8
kdebase-3.5.8-5.fc8

How reproducible:

To chamge Gnome to KDE and start X Window System.

Steps to Reproduce:
1. Change Gnome to KDE
2. Start X Window System
3.
  
Actual results:
aRts show error message like "can not inialize playback defice". 

Also

# artsd -F 10 -S 4096 -a alsa -s 60 -m artsmessage -c drkonqi -l 3 -f
*** PULSEAUDIO: Unable to connect: Connection refused
artsmessage: cannot connect to X server

Expected results:
arts run and working...

Additional info:

fedora8test3 is updated to:

[sergeil@homedesk ~]$ date -R
Sat, 03 Nov 2007 15:48:58 +0200
Comment 1 Rex Dieter 2007-11-03 10:52:42 EDT
kde-settings-pulseaudio includes the support to enable pulseaudio.

yum groupinstall kde-desktop 
will ensure that (as well as any other new default components) it is installed 
Comment 2 Sergei LITVINENKO 2007-11-03 13:40:03 EDT
Sorry, it is my mistake. I was sure, all related rpm packets will be installed
by dependences. But not all is so strict.
Comment 3 Rex Dieter 2007-11-03 14:19:50 EDT
It's not strict wrt pulseaudio, since it is possible to run kde without it.

Note You need to log in before you can comment on or make changes to this bug.