Bug 36520 - xfree86 svga driver does not work for Diamond Speedstar a90 (savage4 pro+)
Summary: xfree86 svga driver does not work for Diamond Speedstar a90 (savage4 pro+)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-18 17:44 UTC by Joseph Apuzzo
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 23:46:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Working 8 bit config and log files (5.85 KB, tar/gzip)
2001-06-30 08:56 UTC, Charles Liebenberg
no flags Details
16 bit config and logs - not working (12.17 KB, tar/gzip)
2001-06-30 08:58 UTC, Charles Liebenberg
no flags Details
Sorry - in the other 16 bit tgz file I included the wrong log files - this one is OK (12.02 KB, tar/gzip)
2001-06-30 09:36 UTC, Charles Liebenberg
no flags Details

Description Joseph Apuzzo 2001-04-18 17:44:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)


Have a Diamond SpeedStar a90 which is based on the  Savage4 pro+ chip (with 16mb)
I can not get better then 8bit 800x600 resolution from the svga driver in XFree86
When at a higher resolution the screen is undeadable ( but does not flicker ) you see what sort of looks like the desktop with white vertical 
bars.
This did not happen in v6.2 or v7.0 

Reproducible: Always
Steps to Reproduce:
1.Set XFree86 to any Savage4 setting
2.Run startx
3.
	

Actual Results:  Always get crupt screen, execpt at 8bit, 800x600 or less

Expected Results:  Works at least as good as 7.0
Would like to have a working excelorated Savage4 driver

Please contact me if you need more information or wish that I try somthing
japuzzo@hotmail.com

Comment 1 Mike A. Harris 2001-04-20 20:54:48 UTC
Please try the 4.0.3-9 release from my dir at:

ftp://people.redhat.com/mharris

Does this fix the problem?

Comment 2 Charles Liebenberg 2001-06-28 13:55:23 UTC
Exact same problem except I have only 1600x1400 @ 8 bit working

Using Savage4 (16mb)

Comment 3 Alexei Podtelezhnikov 2001-06-28 19:26:43 UTC
Would you "Create a new attachement" using the link bellow for the following 
two files:
/etc/X11/XF86Config-4 and /var/log/XFree86.*.log, please

Comment 4 Charles Liebenberg 2001-06-30 08:56:49 UTC
Created attachment 22266 [details]
Working 8 bit config and log files

Comment 5 Charles Liebenberg 2001-06-30 08:58:54 UTC
Created attachment 22267 [details]
16 bit config and logs - not working

Comment 6 Charles Liebenberg 2001-06-30 09:36:41 UTC
Created attachment 22268 [details]
Sorry - in the other 16 bit tgz file I included the wrong log files - this one is OK

Comment 7 Mike A. Harris 2001-08-13 23:45:59 UTC
I've got some feedback that this is fixed in the Rawhide version
of XFree86 4.1.0-0.9.11.  Could you confirm this please?


Note You need to log in before you can comment on or make changes to this bug.