Bug 365521 - TAHI--DHCPv6--The recieved Relay-reply message do not include Advertise message
TAHI--DHCPv6--The recieved Relay-reply message do not include Advertise message
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.0
All Linux
urgent Severity medium
: rc
: ---
Assigned To: David Cantrell
:
: 363571 (view as bug list)
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-11-04 01:16 EST by Zhiyong Wu
Modified: 2009-06-15 07:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 17:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-11-04 01:16:12 EST
Description of problem:

  When having dhcpv6 tests in the server mode,we found that The recieved Relay-

reply message do not include Advertise message in some scenarios.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   The recieved Relay-reply message do not include Advertise message

Expected results:

   The recieved Relay-reply message should include Advertise message

Additional info:
  
   please refer to 

http://focus.brisbane.redhat.com/~zwu/dhcp_server/20071101/DHCPv6_Self_Test_P2_
1_0_7_server/rfc3315/index.html

   (1) 37 Part C : Relay-Reply message transmission through the layered Relay 
agents
Comment 1 RHEL Product and Program Management 2007-11-07 05:34:53 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 David Cantrell 2008-01-15 23:38:36 EST
Fixed upstream and will be in dhcpv6-1.0.5.
Comment 5 Zhiyong Wu 2008-02-20 03:57:54 EST
I thank that the test reports with dhcpv6-1.0.4 on rhel5.2 should be same with
those with dhcpv6-1.0.10 on rhel5.2

the bug still exists when using dhcpv6-1.0.10 to have a test.

for the test result, pls see:

(1)http://focus.brisbane.redhat.com/~zwu/RHEL5.2-Server-20080212.0/20080220/DHCPv6_Self_Test_P2_1_0_8_server_1.0.10/rfc3315/37.html
Comment 6 Zhiyong Wu 2008-02-20 04:01:03 EST
a more thing, they are all running tests on dhcpv6 server.
Comment 8 Denise Dumas 2008-02-27 10:23:20 EST
In order to debug this problem, we need the test case for RHEL 5.2 with an exact
reproducer, including output with verbose debugging messages from the DHCPV6
software.  One way to do this would be to extract the commands that TAHI runs.
The man pages for dhcp6s, dhcp6r, and dhcp6c all show how to generate verbose
debug messages. 
Comment 9 David Cantrell 2008-03-11 15:46:17 EDT
*** Bug 363571 has been marked as a duplicate of this bug. ***
Comment 11 David Cantrell 2008-03-12 16:15:16 EDT
Fixed in dhcpv6-1.0.10-2.el5.
Comment 17 David Cantrell 2008-06-03 17:14:00 EDT
The current version of dhcpv6 does not work with multiple relays.  This is a known problem and will be 
addressed upstream.
Comment 18 RHEL Product and Program Management 2008-06-03 17:21:14 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.