Bug 36577 - Agfa 1236s SCSI + aha152x do scanning in a very strange way.
Agfa 1236s SCSI + aha152x do scanning in a very strange way.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sane (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 17:30 EDT by Anvil
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-03 07:14:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anvil 2001-04-18 17:30:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.4.3 i686)


I tried to make a _color_ scan (grayscale worked) with an aha152x and SCSI
AGFA 1236s and output picture seems to be dissassembled..

Reproducible: Always
Steps to Reproduce:
1. modprobe aha152x
2. modprobe sg
3. be sure to have permission on /dev/sg*
4. xsane &
5. Choose scanner -> /dev/sga
6. maybe acquire preview...
7. Scan in color mode..
8. ee output.pnm & (where output.pnm is the pic from the scanner)
	

Actual Results:  You may see what happened by looking at this url : 
http://confiote.ath.cx/~anvil/pwetpwet.pnm <-- the bad color scan
http://confiote.ath.cx/~anvil/pwetpwet2.pnm <-- The grayscale scan
Here the color scan is "different".

Expected Results:  The color scan should be like the grayscale one.. with
colors.. =]
Comment 1 Tim Waugh 2001-04-19 06:13:39 EDT
Are you able to try out a new snapscan backend?  Take a look at 
http://snapscan.sourceforge.net/ to find out about it.
Comment 2 Anvil 2001-04-19 08:45:11 EDT
Yeah man.. that rox.. =]
I think you should have a look at
http://confiote.ath.cx/~anvil/sane-1.0.4-dams.src.rpm
I explain what i've done :
1/ get sane-backends-1.0.4.tar.gz
2/ get snapscan-20010411.tar.gz
3/ tar zxvf sane-backends-1.0.4.tar.gz
4/ ln -s sane-backends-1.0.4 sane-1.0.4
5/ tar zcvf sane-backends-1.0.4.tar.gz sane-backends-1.0.4 sane-1.0.4
6/ I modified slightly the sane.spec from 1.0.3.src.rpm (from SRPMS seawolf iso)
(minor changes.. do diff sane-1.0.3.spec sane.from.me.spec to see)
7/ Put snapscan-20010411.tar.gz and the new sane-backends-1.0.4.tar.gz into
/usr/src/redhat/SOURCES
8/ rpm -ba sane.spec
9/ Build was very successful so rpm -Uvh sane-1.0.4-dams.i386.rpm
10/ Differences in xsane :
	-> preview can be made in colour mode.
	-> colour scanning is great. you could see the result at
http://confiote.ath.cx/~anvil/coincoin.pnm (and compare with old colour scan..;)

it seems to really work now
Thanks a lot for the hint.
Comment 3 Tim Waugh 2001-06-05 04:50:34 EDT
I've put packages for pre-1.0.5 in rawhide, if you'd like to test them out.  
The 1.0.5 release is quite soon.

Comment 4 Anvil 2001-06-05 06:16:05 EDT
I've made some scan with this packages and it seems to work good.
Thank you =]
For me, the bug is definitly resolved.

Note You need to log in before you can comment on or make changes to this bug.