Bug 36579 - IInstaller crashes after chosing partitions
IInstaller crashes after chosing partitions
Status: CLOSED DUPLICATE of bug 19468
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 18:04 EDT by Rasmus Richter
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 18:09:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rasmus Richter 2001-04-18 18:04:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [de] (Win98; I)


During an installation via nfs the installer crashes after the point were to choose which partitions to be formatted. I did think I'd everything like 
discribed in the documentation. It seems even the anaconda-update from september will not fix the problem.

Reproducible: Always
Steps to Reproduce:
1. Start installation with "linux updates"
2. Use Update-Disk
3.
	

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 463, in setScreen
    direction ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/package_gui.py", line 426, in getScreen
    self.todo.getHeaderList ()
  File "/tmp/updates/todo.py", line 532, in getHeaderList
    self.hdList = self.method.readHeaders()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 22, in readHeaders
    return HeaderListFromFile(self.tree + "/RedHat/base/hdlist")
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 136, in __init__
    hdlist = rpm.readHeaderListFromFile(path)
rpm.error: (2, 'Datei oder Verzeichnis nicht gefunden')

Local variables in innermost frame:
compatPackages: None
self: <comps.HeaderListFromFile instance at 854a3f0>
path: /mnt/source/./RedHat/base/hdlist

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
NfsInstallMethod
p4
(dp5
S'tree'
p6
S'/mnt/source/.'
sbsS'initlevel'
p7
I3
sS'progressWindow'
p8
NsS'expert'
p9
I0
sS'ddruidReadOnly'
p10
I0
sS'bootdisk'
p11
I1
sS'language'
p12
(itodo
Language
(dp13
S'abbrevMap'
p14
(dp15
S'es_ES'
p16
S'Spanish'
p17
sS'tr_TR'
p18
S'Turkish'
p19
sS'sr_YU'
p20
S'Serbian'
p21
sS'de_DE'
p22
S'German'
p23
sS'sk_SK'
p24
S'Slovak'
p25
sS'ru_RU.KOI8-R'
p26
S'Russian'
p27
sS'is_IS'
p28
S'Icelandic'
p29
sS'no_NO'
p30
S'Norwegian'
p31
sS'sv_SE'
p32
S'Swedish'
p33
sS'en_US'
p34
S'English'
p35
sS'it_IT'
p36
S'Italian'
p37
sS'da_DK'
p38
S'Danish'
p39
sS'cs_CZ'
p40
S'Czech'
p41
sS'uk_UA.KOI8-U'
p42
S'Ukrainian'
p43
sS'hu_HU'
p44
S'Hungarian'
p45
sS'fr_FR'
p46
S'French'
p47
sS'sl_SI'
p48
S'Slovenian'
p49
sS'ro_RO'
p50
S'Romanian'
p51
ssS'font'
p52
(dp53
g37
S'lat0-sun16'
sg21
S'cyr-sun16'
sg27
S'cyr-sun16'
sg35
S'None'
sg25
S'lat2-sun16'
sg31
S'lat0-sun16'
sg33
S'lat0-sun16'
sg47
S'None'
sg49
S'lat2-sun16'
sg51
S'lat2-sun16'
sg23
S'None'
sg19
S'lat5-sun16'
sg45
S'lat2-sun16'
sg17
S'None'
sg43
S'cyr-sun16'
sg41
S'lat2-sun16'
sg39
S'lat0-sun16'
sg29
S'lat0-sun16'
ssS'langs'
p54
(dp55
g37
g36
sg21
g20
sg27
g26
sg35
g34
sg25
g24
sg31
g30
sg33
g32
sg47
g46
sg49
g48
sg51
g50
sg23
g22
sg19
g18
sg45
g44
sg17
g16
sg43
g42
sg41
g40
sg39
g38
sg29
g28
ssS'info'
p56
(dp57
S'LANG'
p58
g22
ssS'map'
p59
(dp60
g37
S'iso15'
sg21
S'iso05'
sg27
S'koi8-r'
sg35
S'None'
sg25
S'iso02'
sg31
S'iso15'
sg33
S'iso15'
sg47
S'None'
sg49
S'iso02'
sg51
S'iso02'
sg23
S'None'
sg19
S'iso09'
sg45
S'iso02'
sg17
S'None'
sg43
S'koi8-u'
sg41
S'iso02'
sg39
S'iso15'
sg29
S'iso15'
ssS'lang'
p61
g22
sbsS'fstab'
p62
NsS'lilo'
p63
(ililo
LiloConfiguration
(dp64
S'liloDevice'
p65
S'mbr'
p66
sS'initrdsMade'
p67
(dsS'edd'
p68
I0
sS'default'
p69
NsS'liloImages'
p70
(dsS'liloLinear'
p71
I1
sS'liloAppend'
p72
S''
sbsS'comps'
p73
NsS'network'
p74
(itodo
Network
(dp75
S'netdevices'
p76
(dp77
S'eth0'
p78
(itodo
NetworkDevice
(dp79
g56
(dp80
S'ONBOOT'
p81
S'yes'
p82
sS'IPADDR'
p83
S'192.168.1.2'
sS'DEVICE'
p84
g78
sS'NETWORK'
S'192.168.1.0'
sS'BOOTPROTO'
p85
S'static'
sS'NETMASK'
p86
S'255.255.255.0'
sS'BROADCAST'
S'192.168.1.255'
ssbssS'gateway'
p87
S'192.168.1.254'
sS'secondaryNS'
p88
S''
sS'hostname'
p89
S'localhost.localdomain'
p90
sS'primaryNS'
p91
S'192.168.1.1'
sS'domains'
p92
(lsS'isConfigured'
p93
I1
sS'readData'
p94
I1
sS'ternaryNS'
p95
S''
sbsS'upgrade'
p96
I0
sS'instClass'
p97
(iworkstation
InstallClass
(dp98
S'rootPasswordCrypted'
p99
I0
sS'nameserver'
p100
S''
sS'x'
NsS'rootPassword'
p101
NsS'makeBootdisk'
p102
I1
sS'installType'
p103
NsS'postScript'
p104
NsS'earlySwapOn'
p105
I0
sS'networkDevice'
p106
NsS'clearText'
p107
Nsg63
(g66
I1
S''
tsg12
NsS'name'
p108
S''
sS'postInChroot'
p109
I0
sS'pixmap'
p110
S''
sS'partitions'
p111
(lp112
(S'/boot'
p113
(I16
I-1
I0
t(S''
I-1
I0
t(I0
I0
tNta(S'/'
(I700
I-1
I1
t(S''
I-1
I0
t(I0
I0
tNta(S'swap'
p114
(I64
I-1
I0
t(S''
I-1
I0
t(I0
I0
tNtasS'clearType'
p115
S'wkst'
p116
sg87
S''
sS'mouse'
p117
NsS'packages'
p118
NsS'timezone'
p119
NsS'zeroMbr'
p120
I0
sS'keyboard'
p121
NsS'groups'
p122
(lp123
S'Workstation Common'
p124
asS'bootProto'
p125
NsS'netmask'
p126
S''
sS'raidList'
p127
(lsS'skipSteps'
p128
(dp129
S'authentication'
p130
I1
sg63
I1
ssS'auth'
p131
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsg89
S'localhost.localdomain'
p132
sg62
(lsS'showgroups'
p133
(lp134
S'KDE'
p135
aS'GNOME'
p136
aS'Games'
p137
asS'ip'
p138
S''
sS'defaultRunlevel'
p139
NsS'desktop'
p140
S''
sS'clearPartText'
p141
S'You are about to erase any preexisting Linux installations on your system.'
p142
sS'clearParts'
p143
I2
sbsS'rootpassword'
p144
NsS'extraModules'
p145
(lp146
sg117
(imouse
Mouse
p147
(dp148
S'device'
p149
S'psaux'
p150
sg56
(dp151
S'XMOUSETYPE'
p152
S'PS/2'
p153
sS'FULLNAME'
p154
S'Generic - 2 Button Mouse (PS/2)'
sS'MOUSETYPE'
p155
S'ps/2'
p156
ssS'emu'
p157
I0
sS'wasProbed'
p158
I1
sS'emulate'
p159
I1
sbsS'ddruidAlreadySaved'
p160
I0
sS'serial'
p161
I0
sg119
(S'Europe/Berlin'
I0
I0
tsg120
I0
sg121
(ikbd
Keyboard
(dp162
S'layout'
p163
NsS'model'
p164
NsS'type'
p165
S'PC'
p166
sg56
(dp167
S'KEYBOARDTYPE'
p168
S'pc'
p169
sS'KEYTABLE'
p170
S'de-latin1'
p171
ssbsS'fdDevice'
p172
S'fd0'
p173
sS'installSystem'
p174
I1
sS'setupFilesystems'
p175
I1
sg131
(itodo
Authentication
(dp176
S'useNIS'
p177
I0
sS'nisServer'
p178
S''
sS'useLdap'
p179
I0
sS'krb5Kdc'
p180
S''
sS'useHesiod'
p181
I0
sS'ldapServer'
p182
S''
sS'nisDomain'
p183
S''
sS'krb5Realm'
p184
S''
sS'useLdapauth'
p185
I0
sS'hesiodRhs'
p186
S''
sS'useShadow'
p187
I1
sS'nisuseBroadcast'
p188
I0
sS'useKrb5'
p189
I0
sS'useMD5'
p190
I1
sS'ldapBasedn'
p191
S''
sS'krb5Admin'
p192
S''
sS'hesiodLhs'
p193
S''
sS'hesiodDlhs'
p194
S''
sbsg89
g132
sS'reconfigOnly'
p195
I0
sS'x'
(ixf86config
XF86Config
p196
(dp197
S'monlist'
p198
(dsS'keyModel'
p199
S'pc102'
p200
sS'monids'
p201
(dsg149
NsS'monEisa'
p202
NsS'server'
p203
S'XF86_SVGA'
sS'monHoriz'
p204
S'31.5'
p205
sS'devID'
p206
S'Trident TGUI9660 (generic)'
p207
sS'descr'
p208
S'Trident Microsystems|TGUI 9660/968x/968x'
p209
sS'modes'
p210
(dp211
S'8'
(lp212
S'640x480'
p213
assS'keyOptions'
p214
S''
sS'keyVariant'
p215
S''
sS'monID'
p216
S'Unprobed Monitor'
p217
sS'keyLayout'
p218
S'de'
p219
sS'manualModes'
p220
(dsg117
g147
sS'keyRules'
p221
S'xfree86'
p222
sS'monVert'
p223
S'60'
p224
sS'cardMan'
p225
S'Copyright 1994 TRIDENT MICROSYSTEMS INC.'
p226
sS'monSect'
p227
S''
sS'primary'
p228
I0
sS'vidRam'
p229
S'2048'
sS'probed'
p230
I1
sS'monName'
p231
NsS'vidCards'
p232
(lp233
(dp234
S'SERVER'
S'SVGA'
sS'NAME'
g207
sS'VENDOR'
p235
g226
sS'NOCLOCKPROBE'
S''
sS'CHIPSET'
S'TGUI9660'
sasS'skip'
p236
I0
sS'files'
p237
S'\012# The location of the RGB database.  Note, this is the name of the\012# file minus the extension (like ".txt" or ".db").  There is 
normally\012# no need to change the default.\012\012    RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are allowed 
(they are concatenated together)\012# By default, Red Hat 6.0 and later now use a font server independent of\012# the X server to render 
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    FontPath   "unix/:7100"\012'
p238
sbsS'users'
p239
NsS'instPath'
p240
S'/mnt/sysimage'
p241
sS'intf'
p242
NsS'hdList'
p243
Nsb.
Comment 1 Brent Fox 2001-04-18 18:09:43 EDT

*** This bug has been marked as a duplicate of 19468 ***

Note You need to log in before you can comment on or make changes to this bug.