Bug 36598 - bugs in /usr/share/printconf/foomatic/mfomatic
bugs in /usr/share/printconf/foomatic/mfomatic
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 20:33 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 20:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-18 20:33:40 EDT
It doesn't generate PJL output because of two bugs.  The first is
checking the size of the prepend and the append arrays.  The second
is that the prepend array size was checked instead of the append
array at the end of the job.

(rob:90) diff mfomatic.orig mfomatic
347c347
<           "\33%-12345X\@PJL RESET\n\@PJL EOJ\n");
---
>           "\033%-12345X\@PJL RESET\n\@PJL EOJ\n");
553c553
<           if ( @pjlprepend > 1 ) {
---
>           if ( @pjlprepend > 0 ) {
559c559
<           if ( @pjlprepend > 1 ) {
---
>           if ( @pjlappend > 0 ) {
Comment 1 Crutcher Dunnavant 2001-07-30 17:50:54 EDT
fixed.

Note You need to log in before you can comment on or make changes to this bug.