This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 366111 - Intel PRO/Wireless 3945ABG fails to connect to some networks
Intel PRO/Wireless 3945ABG fails to connect to some networks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 15:59 EST by Sven Oehme
Modified: 2008-06-27 19:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-27 19:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
debug level 5 log (39.04 KB, text/plain)
2007-11-04 16:00 EST, Sven Oehme
no flags Details
additional infos (2.74 KB, text/plain)
2007-11-04 16:00 EST, Sven Oehme
no flags Details
with modprobe iwl3945 debug=1 (1.54 KB, text/plain)
2008-02-12 19:58 EST, Sven Oehme
no flags Details
aditional log with different options .. (31.19 KB, text/plain)
2008-02-12 20:00 EST, Sven Oehme
no flags Details

  None (edit)
Description Sven Oehme 2007-11-04 15:59:24 EST
Description of problem:

I tried to connect to a WIFI Network from orange (France telekom Provider) and i
wasn't able to connect to the network 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. bring up system
2. scan for network provider
3. connect to orange network ...
  
Actual results:

i get a connect (based on iwconfig) but a few seconds later the connection is
broken and i don't receive a dhcp address, the network link goes down. 

Expected results:

i get  dhcp address and can browse ..

Additional info:

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)

i will attach a debug level 5 log ..
Comment 1 Sven Oehme 2007-11-04 16:00:17 EST
Created attachment 247661 [details]
debug level 5 log
Comment 2 Sven Oehme 2007-11-04 16:00:42 EST
Created attachment 247671 [details]
additional infos
Comment 3 Matthias Saou 2007-11-20 15:51:47 EST
Reassigning against the kernel, since this isn't a firwmare package specific bug.
Comment 4 Sven Oehme 2007-12-06 04:26:04 EST
is there anything else i can provide ? 
Comment 5 Matthias Saou 2008-02-03 13:16:12 EST
Reassigning properly with owner change (oops!).
Comment 6 Christopher Brown 2008-02-03 18:43:37 EST
Re-assigning to wireless maintainer. Please test against a 2.6.24-based kernel
when you are able and update this bug.
Comment 7 John W. Linville 2008-02-04 08:48:30 EST
If problems persist with current F8 kernels, please try adding "options 
iwl3945 disable_hw_scan=1" to /etc/modprobe.conf.  Does that change the 
situation for you?
Comment 8 Sven Oehme 2008-02-05 15:18:13 EST
i updated to the latest fc9 kernel from kojo , that fixed my problem .
Comment 9 Christopher Brown 2008-02-05 20:10:27 EST
Thanks for the update Sven. Closing to reflect that then...
Comment 10 Sven Oehme 2008-02-12 19:57:32 EST
ok, sorry, have to reopen .. i just did hit it again and did created some debug
logs ..
Comment 11 Sven Oehme 2008-02-12 19:58:20 EST
Created attachment 294716 [details]
with modprobe iwl3945 debug=1

log with debug=1 nothing else
Comment 12 Sven Oehme 2008-02-12 20:00:26 EST
Created attachment 294717 [details]
aditional log with different options .. 

look at this : 

iwl3945: Microcode SW error detected.  Restarting 0x82000008.
iwl3945: I iwl3945_irq_handle_error Restarting adapter due to uCode error.
iwl3945: Error Reply type 0x00000005 cmd REPLY_TX (0x1C) seq 0x000B ser
0x0000004B
iwl3945: U iwl3945_send_cmd_sync Command REPLY_RXON failed: FW Error
iwl3945: Error setting new configuration (-5).
iwl3945: U __iwl3945_down iwl3945 is going down
iwl3945: Can't stop Rx DMA.
iwl3945: U iwl3945_hw_nic_stop_master stop master
Comment 13 John W. Linville 2008-02-25 15:59:46 EST
http://bughost.org/bugzilla/show_bug.cgi?id=1616
Comment 14 John W. Linville 2008-03-13 11:29:21 EDT
Is this still a problem with recent F8 kernels?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42735

And/or recent rawhide kernels?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42641
Comment 15 Sven Oehme 2008-04-13 12:13:20 EDT
yes it works .. you can close this one . 
Comment 16 John Poelstra 2008-06-27 19:52:02 EDT
closing

Note You need to log in before you can comment on or make changes to this bug.