Bug 366151 - 'Component is not available' exception in nsSessionStore.js with firefox-2.0.0.8-2.fc8
'Component is not available' exception in nsSessionStore.js with firefox-2.0....
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-04 16:26 EST by Luke Macken
Modified: 2016-09-19 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 08:04:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2007-11-04 16:26:05 EST
Description of problem:
I'm frequently receiving the following error message in Firebug when using
firefox-2.0.0.8-2.fc8.  I am unable to reproduce this error on firefox-2.0.0.8-1.fc7

[Exception... "Component is not available" nsresult: "0x80040111
(NS_ERROR_NOT_AVAILABLE)" location: "JS frame ::
file:///usr/lib/firefox-2.0.0.8/components/nsSessionStore.js :: sss_saveState ::
line 1749" data: no]
[Break on this error] oState.session = { state: ((this._loadState ==
STATE_RUNNING) ? STATE_RUNNIN...
Comment 1 Matěj Cepl 2007-11-07 09:25:16 EST
Could you test with the latest firefox build available at
http://koji.fedoraproject.org/koji/buildinfo?buildID=23359, please?
Comment 2 Luke Macken 2007-12-09 13:25:39 EST
I seem to still be getting this message, even with firefox-2.0.0.10-2.fc8:

[Exception... "Component is not available" nsresult: "0x80040111
(NS_ERROR_NOT_AVAILABLE)" location: "JS frame ::
file:///usr/lib/firefox-2.0.0.10/components/nsSessionStore.js :: sss_saveState
:: line 1749" data: no]
[Break on this error] oState.session = { state: ((this._loadState ==
STATE_RUNNING) ? STATE_RUNNIN...
Comment 3 Christopher Aillon 2007-12-13 08:04:45 EST
https://bugzilla.mozilla.org/show_bug.cgi?id=366509

Note You need to log in before you can comment on or make changes to this bug.