This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 36621 - Can't create boot floppy with bootnet.img
Can't create boot floppy with bootnet.img
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 02:11 EDT by Shane Hill
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 11:43:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Additional cases of not being able to make boot floppies during install (302 bytes, text/plain)
2001-04-22 15:23 EDT, Need Real Name
no flags Details

  None (edit)
Description Shane Hill 2001-04-19 02:11:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)


If I run the installer using bootnet.img and NFS the installation UPGRADE 
process runs fine until I get to the "Create Boot Floppy" screen. After 
inserting a formatted floppy and pressing next, the installer refuses to 
accept that a valid floppy disk has been supplied. I then select skip and 
the installer continues and reboots the system. After the reboot I then 
discover that the booted kernel from the MBR is not 2.4.2-2 but my 
previous 2.2.17-14. 2.4.2 seems to be installed, but not configured.

I have used bootnet.img twice now on different systems and I get the same 
problem. However, if I run the upgrade directly off the boot CD-ROM the 
whole upgrade process works fine; the boot floppy is created and the 2.4.2 
kernel is installed and configured in lilo.

Reproducible: Always
Steps to Reproduce:
1. See description.
2.
3.
	

Actual Results:  No boot floppy created and kernel not upgraded to 2.4.2.

Expected Results:  Boot floppy created and kernel 2.4.2 installed and 
configured by lilo.

To fix the effected machines, I have to reapply the kernel-2.4.2.rpm and 
configure lilo to redo the MBR and then create a boot floppy with 
mkbootdisk.
Comment 1 Brent Fox 2001-04-19 16:02:05 EDT
Do you have an LS-120 drive in this machine?
Comment 2 Shane Hill 2001-04-19 18:50:05 EDT
No, both the machines I upgraded with bootnet.img just have standard 1.44Mb 
floppy drives. We have very few LS-120 drives on our site. The upgrade process 
works fine straight off the boot CD; created from the ISO images. Could the 
problem be elsewhere, eg: a missing file after copying the distribution to a 
single directory from the two ISO images.
Comment 3 Need Real Name 2001-04-22 15:23:34 EDT
Created attachment 16045 [details]
Additional cases of not being able to make boot floppies during install
Comment 4 Shane Hill 2001-04-22 20:09:03 EDT
The blank floppy I used came straight out of a new box. The bootnet.img 
installer would not touch it, but the boot CDROM installer was able to use the 
same floppy disk fine.
Comment 5 Shane Hill 2001-04-22 20:20:28 EDT
If anyone wants me to try the bootnet.img on a third machine I can do this. If 
so, are there any suggestions on how I could supply any more useful 
information. I checked all the console screens (1 through 7) on the first two 
upgrades with bootnet.img, but didn't notice any unusual error or warning 
messages.
Comment 6 Brent Fox 2001-04-24 15:36:58 EDT
Sure, try it on a third machine.  These aren't USB floppy drives, or anything
else out of the ordinary, are they?  I just did an install on my test machine
using a bootnet.img and the installer make a boot disk just fine.
Comment 7 Shane Hill 2001-04-25 20:20:29 EDT
No, they are just normal internal floppy drives. I'll upgrade another machine 
soon. I just need to determine a time I can upgrade machine when no other users 
are working on it.
Comment 8 Brent Fox 2001-04-26 15:53:15 EDT
Putting in NEEDINFO state until you get a chance to test this out.
Comment 9 Shane Hill 2001-05-02 22:59:52 EDT
Well I have upgraded another two machines now with the bootnet.img and 
everything proceeded fine without a problem. Strange because these two machines 
are identical (and I mean exactly identical hardware wise) to the first two 
that did not install correctly. The only difference was that I rebuilt the 
RedHat NFS source directory off the CDROMs hoping that something may have gone 
wrong the first time I did this.
ie. "cp -a /mnt/cdrom/RedHat /mirror/rh7.1" for both CDROMs

I have two more machines to go, so if anything happens with these I'll be back 
with more info.

Thanks and Have Fun!!

Shane
Comment 10 Brent Fox 2001-05-03 11:43:09 EDT
Good.  I'm glad things seem to be working out.  I'm going to close the bug now
because the installer appears to be working.  But please reopen this bug if you
see any more problems.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.