Bug 36626 - divide error: 0000 on loading ncr53c8xx.o
divide error: 0000 on loading ncr53c8xx.o
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 07:25 EDT by Klaus Muth
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 10:26:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Muth 2001-04-19 07:25:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.14-5.0 i686)


The kernel shows an "divide error" on loading ncr53c8xx.o
and lsmod shows
ncr53c8xx: (initializing) forever.

The ncr controller does not work, the kernel module is not
removable (device busy)

Reproducible: Always
Steps to Reproduce:
1. Upgrade 7.0 -> 7.1 with this adapter
2. The error shows at installation, when loading the module and
   later at every boot
		
	

The error message as reported in /var/log/dmesg is:
...
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
ncr53c8xx: at PCI bus 0, device 10, function 0
ncr53c8xx: 53c860 detected with Symbios NVRAM
ncr53c860-0: rev 0x2 on pci bus 0 device 10 function 0 irq 10
ncr53c860-0: NCR clock is 80802KHz, 80074KHz
divide error: 0000
CPU:    0
EIP:    0010:[<d081f883>]
EFLAGS: 00010246
eax: 026259ff   ebx: e8001000   ecx: 00000000   edx: 00000000
esi: ffffffff   edi: c178c000   ebp: c178c000   esp: cfc2bb3c
ds: 0018   es: 0018   ss: 0018
Process insmod (pid: 13, stackpage=cfc2b000)
Stack: e8001000 cfc2bba0 cfc2bba0 c178c000 d082008c c178c000 cfc2bba0
d082f000
       cfc2bba0 cfd10e20 c178e000 00000000 d082b0e0 c178e000 d081f005
d082b0e0
       00000000 c178e000 d082d000 00000080 d0826f5d cfc2bba0 00000000
00000001
Call Trace: [<e8001000>] [<d082008c>] [<d082f000>] [<d082b0e0>]
[<d081f005>] 
[<d082b0e0>] [<d082d000>]
       [<d0826f5d>] [<d082b0e0>] [<d082b0e0>] [<d08266c0>] [<d082b0e0>] 
[<d082b0b0>] [<d081d000>] [<d0801ba4>]
       [<d082b0e0>] [<d081d000>] [<d08266f7>] [<d082b0e0>] [<d082b0e0>] 
[<c0116e05>] [<d082b298>] [<d0819000>]
       [<d081d060>] [<c010901b>]
 
Code: f7 f1 89 c1 81 f9 fa 00 00 00 77 09 c6 87 13 0b 00 00 0a eb
...

There is no bios on the ncr, there is a cdrw attached.
ncr & cdrw are now unusable.

It did work without problems on 7.0
Comment 1 Arjan van de Ven 2001-04-19 07:32:34 EDT
Can you try to use the sym53c8xx.o module instead ? 
It's for the same hardware (more or less).
If that works, please give the output of "lspci -v" so we can make the sym
driver the default for this type of card.
Comment 2 Klaus Muth 2001-04-19 08:25:28 EDT
Puh! It was not simple to get the ncr module removed, it resided in the
initrd :(. Took me 1/2h to find it...

After rebooting without the ncr module, there was a clean boot without
the divide error but I got it again after entering
modprobe sym53c8xx:
I got an Segmentation Fault in the shell, and dmesg says:
SCSI subsystem driver Revision: 1.00
sym53c8xx: at PCI bus 0, device 10, function 0
sym53c8xx: setting PCI_COMMAND_PARITY...(fix-up)
sym53c8xx: 53c860 detected with Symbios NVRAM
sym53c860-0: rev 0x2 on pci bus 0 device 10 function 0 irq 10
sym53c860-0: NCR clock is 80074KHz
divide error: 0000
CPU:    0
EIP:    0010:[<d0a30fea>]
EFLAGS: 00010246
eax: 026259ff   ebx: 0000e800   ecx: 00000000   edx: 00000000
esi: c9760000   edi: ffffffff   ebp: c9760000   esp: c9829b48
ds: 0018   es: 0018   ss: 0018
Process modprobe (pid: 929, stackpage=c9829000)
Stack: 0000e800 e8001000 c9829bb4 c9760000 d0a31972 c9760000 c9829bb4 c9760000
       c9760000 d08cc000 c9829bb4 cd47e960 c9762000 00000000 d0a3f020 00000000
       d0a39584 d0a3f020 00000000 c9762000 d08ca000 00000080 c9829bb4 c9762000
Call Trace: [<e8001000>] [<d0a31972>] [<d08cc000>] [<d0a3f020>] [<d0a39584>] 
[<d0a3f020>] [<d08ca000>]
       [<d0a30000>] [<d0a3f020>] [<d0932ba4>] [<d0a3f020>] [<d0a34060>] 
[<c01090c4>] [<d0a34060>] [<c0250018>]
       [<c0250018>] [<d0a30000>] [<d0a3b4a7>] [<d0a3f020>] [<d0a3f020>] 
[<c0116e05>] [<d0a3f21c>] [<d0931000>]
       [<d0a30060>] [<c010901b>]
 
Code: f7 f1 89 c1 81 f9 fa 00 00 00 77 0a c6 86 44 04 00 00 0a eb

*sigh*
Comment 3 Klaus Muth 2001-04-25 10:33:33 EDT
Still nogo. Is there anything I can do to get this NCR to work?
lspci -v output for this controller:

00:0a.0 SCSI storage controller: Symbios Logic Inc. (formerly NCR) 53c860 (rev
02)
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at e800 [size=256]
        Memory at e8001000 (32-bit, non-prefetchable) [size=256]

Comment 4 Pieter Langendonck 2001-05-04 12:42:29 EDT
I have exactly the same problem.
Comment 5 Arjan van de Ven 2001-05-09 07:49:41 EDT
The cause for this has been found and a fixed kernel will be released as soon
as possible.
Comment 6 Pieter Langendonck 2001-05-09 12:19:08 EDT
arjanv@redhat.com can you let us know (via mail) when this fix will be
available?
I really waiting for it!...
Thanks.
Comment 7 Arjan van de Ven 2001-05-14 10:26:32 EDT
I have made a driverdisk for use during the installation to fix this problem.

The driverdisk is available from:

http://people.redhat.com/arjanv/rhl71/ncrsym/

and the "readme" file should explain how to use this.

Comment 8 Arjan van de Ven 2001-06-26 09:22:08 EDT
Errata kernel 2.4.3-12 also has this fix.

Note You need to log in before you can comment on or make changes to this bug.