Bug 366411 - On Dell Optiplex 745's can not restart
On Dell Optiplex 745's can not restart
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 01:59 EST by Clint Dilks
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 17:43:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clint Dilks 2007-11-05 01:59:37 EST
Description of problem:

On A Dell Optiplex 745 with Hardware config matching
http://www.smolts.org/show?UUID=5b670987-1ef7-46b3-8e4b-38321240edb3 no matter
what method is selected a machine can not be restarted.  I have tried reboot
shutdown -r now and the graphical options for restarting.  The machine starts
the shutdown sequence and everything appears to be shutdown correctly and you
can see the message indicating that the machine should now restart.  At which
point it hangs.  

Version-Release number of selected component (if applicable):


How reproducible:

Everytime

Steps to Reproduce:
1. Install System and it wont reboot after completion

Or

2.  type reboot inside a terminal

Or

3. type shutdown -r now within a terminal
  
Actual results:

System Hangs

Expected results:

System Reboots

Additional info:
Comment 1 Andrew Case 2007-11-05 13:44:27 EST
Try adding "reboot=h" on the end of your kernel parameters in
/boot/grub/grub.conf.  For example:
   kernel /boot/vmlinuz-2.6.18-8.1.14.el5 ro root=LABEL=/1 rhgb quiet reboot=h


--
Andrew
Comment 2 Clint Dilks 2007-11-05 18:25:13 EST
Tried this no change to behaviour

Anything else I should try or information I can provide ? :)

Clint
Comment 3 Andrew Case 2007-11-05 18:40:21 EST
Clint,

I had this same problem with the Dell Optiplex 745, but I'm running RHEL5.  I
assume you also rebooted after making the change to grub to make it active?  The
"reboot" kernel argument can take several options.  I tried them each until I
found one that worked.  Here's the info regarding the reboot argument:

This option controls the type of reboot that Linux will do when it resets the
computer (typically via /sbin/init handling a Control-Alt-Delete). The default
as of v2.0 kernels is to do a `cold' reboot (i.e. full reset, BIOS does memory
check, etc.) instead of a `warm' reboot (i.e. no full reset, no memory check).
It was changed to be cold by default since that tends to work on cheap/broken
hardware that fails to reboot when a warm reboot is requested. To get the old
behaviour (i.e. warm reboots) use reboot=w or in fact any word that starts with
w will work.

Other accepted options are `c', `b', `h', and `s', for cold, bios, hard, and SMP
respectively. The `s' takes an optional digit to specify which CPU should handle
the reboot. Options can be combined where it makes sense, i.e. reboot=b,s2 

--
From http://tldp.org/HOWTO/BootPrompt-HOWTO-3.html
Comment 4 Clint Dilks 2007-11-06 17:41:30 EST
Hi

It turns out the reboot=b option works for me.  Thanks for the help.  I guess
this is more of a feature than a bug :)

Note You need to log in before you can comment on or make changes to this bug.