Bug 366441 - Passivetex does not process DocBook index
Passivetex does not process DocBook index
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: passivetex (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 03:28 EST by W. Michael Petullo
Modified: 2007-12-17 05:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 10:12:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DocBook XML containing an index (716 bytes, text/xml)
2007-11-05 03:28 EST, W. Michael Petullo
no flags Details
Working Docbook index case (951 bytes, text/xml)
2007-11-29 10:09 EST, Ondrej Vasik
no flags Details

  None (edit)
Description W. Michael Petullo 2007-11-05 03:28:39 EST
Description of problem:
I am trying to process a DocBook index using passivetex. The process fails.

Version-Release number of selected component (if applicable):
passivetex-1.25-5.1.1

How reproducible:
Everytime.

Steps to Reproduce:
Process the attached DocBook XML using "xmlto pdf book.xml"
  
Actual results:
xmlto -x book.xsl pdf book.xml
Making portrait pages on USletter paper (8.5inx11in)
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
(./tmp.fo
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.
xmltex version: 2002/06/25 v1.9 (Exp):
(/usr/share/texmf/tex/xmltex/xmltex.cfg) 
No File: tmp.cfg (/usr/share/texmf/tex/xmltex/passivetex/fotex.xmt)
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2004/02/16 v1.4f Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/xmltex/passivetex/fotex.sty
)
No file tmp.aux.
(/usr/share/texmf/tex/latex/cyrillic/t2acmr.fd)
(/usr/share/texmf/tex/latex/base/ts1cmr.fd)
(/usr/share/texmf/tex/latex/psnfss/t1ptm.fd)
No file tmp.out.
No file tmp.out.
INFO: Using normal, i.e. nonfrench-spacing in document
(/usr/share/texmf/tex/latex/psnfss/t1phv.fd)
(/usr/share/texmf/tex/latex/amsfonts/umsa.fd)
(/usr/share/texmf/tex/latex/amsfonts/umsb.fd)
(/usr/share/texmf/tex/latex/wasysym/uwasy.fd)
(/usr/share/texmf/tex/latex/stmaryrd/ustmry.fd)
Overfull \hbox (1.88567pt too wide) has occurred while \output is active
[][][]  []

Overfull \hbox (1.88567pt too wide) has occurred while \output is active
[][]  []
[1{/usr/share/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]

START 2 COLUMNS

! LaTeX Error: Something's wrong--perhaps a missing \item.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.263 ....maximum="10pt * 1.2" start-indent="0pt">
                                                  D</fo:block></fo:block></f...

? 
! Emergency stop.
 ...                                              
                                                  
l.263 ....maximum="10pt * 1.2" start-indent="0pt">
                                                  D</fo:block></fo:block></f...

!  ==> Fatal error occurred, the output PDF file is not finished!
Transcript written on tmp.log.

Expected results:


Additional info:
Comment 1 W. Michael Petullo 2007-11-05 03:28:39 EST
Created attachment 247771 [details]
DocBook XML containing an index
Comment 2 Ondrej Vasik 2007-11-29 08:42:51 EST
Thanks for report, will try to find the way how to fix it (at least as in the
case of eps images). Anyway this document could be easily translated to pdf by
fop (at least by version 0.94 I'm using for tests).
Comment 3 Ondrej Vasik 2007-11-29 10:09:40 EST
Created attachment 272971 [details]
Working Docbook index case
Comment 4 Ondrej Vasik 2007-11-29 10:10:27 EST
Ok, found that there are some troubles with <indexdiv> ... index example in my
attachment is working properly. 
Comment 5 Ondrej Vasik 2007-12-04 07:58:48 EST
Well, problem is in passivetex lack of support for non-constant expressions. In
param.xsl there are ~4 lines like <xsl:attribute
name="space-before.minimum"><xsl:value-of select="concat($body.font.master,'pt *
X.Y')"/></xsl:attribute> . When you change the line to <xsl:attribute
name="space-before.minimum"><xsl:value-of
select="concat($body.font.master*X.Y,'pt')"/></xsl:attribute> , non-constant
expression is removed and passivetex is able to handle indexdiv data. Anyway -
those data are handled differently from fop - pdf output is wrong, I'm going to
investigate if it is possible to fix that easily.
Comment 6 Ondrej Vasik 2007-12-04 10:12:31 EST
Built as docbook-style-xsl-1.73.2-7.fc9 - non-constant expressions in param.xsl
were changed to constant(counted before concat to string)- Output is now correct
for longer index lists or for column.count.index set to 1 in param.xsl(for
shorter indexes than half of page) - then is the output for indexdiv almost same
as for fop. Closing RAWHIDE, because problem is fixed and there is workaround
for the rest of differences.
Comment 7 Fedora Update System 2007-12-10 15:49:09 EST
docbook-style-xsl-1.73.2-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update docbook-style-xsl'
Comment 8 W. Michael Petullo 2007-12-14 00:48:49 EST
I tried docbook-style-xsl-1.73.2-7.fc9, but get the following error when
processing (note that I only upgraded this one package, I did not update
everything to Rawhide):

xmlto -x book.xsl pdf book.xml
I/O error : Attempt to load network entity
http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl
warning: failed to load external entity
"http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl"
compilation error: file
/home/mike/Documents/articles/disk_encryption_book/book.xsl line 4 element import
xsl:import : unable to load
http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl
sed: can't read /tmp/xmlto.kt3662/book.proc: No such file or directory
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
(./tmp.fo
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.
xmltex version: 2002/06/25 v1.9 (Exp):
(/usr/share/texmf/tex/xmltex/xmltex.cfg) 
No File: tmp.cfg)
*
! Emergency stop.
<*> tmp.fo
          
No pages of output.
Transcript written on tmp.log.
make: *** [book.pdf] Error 1

Downgrading back to Fedora 8's docbook-style-xsl caused the system to function
properly again.
Comment 9 Ondrej Vasik 2007-12-14 04:05:42 EST
There was a problem with drop of release from directory name - see discussion in
#389231 for details. It simply unregistred catalogs in postun - because of same
names - corrected now, it should not occur in next versions. 
Comment 10 W. Michael Petullo 2007-12-15 09:42:26 EST
Ondrej, are you sure that bug #389231 is behind the issue in comment #8? I
didn't see any mention of "Attempt to load network entity" errors in that
report. Or do I need to wait for a newer version of passivetex to be pushed to
Rawhide? I am using passivetex-1.25-5.1.1 and this seems to be the newest
published version.
Comment 11 Ondrej Vasik 2007-12-17 03:59:29 EST
(In reply to comment #10)
> Ondrej, are you sure that bug #389231 is behind the issue in comment #8? 

  Almost, as I experienced the same thing. That was an issue with drop of
release and rpm steps of update - in %post of new package were the new catalogs
registered and in %postun of old package were unregistered - and they had same
name - so result was unregistred catalogs - and therefore failure to load
network entity - which is mapped via catalog to file stored on disk. 


> I didn't see any mention of "Attempt to load network entity" errors in that
> report. Or do I need to wait for a newer version of passivetex to be pushed to
> Rawhide? I am using passivetex-1.25-5.1.1 and this seems to be the newest
> published version.

In fact this message is not problem of passivetex, but more problem of
docbook-style-xsl. See explanation above. I'm quiet sure that it was fixed by
latest builds(should not be a problem after 1.73.2-8.fc9) - and indexdiv was
fixed there too - automated message was about backport to testing version of F7.

Passivetex lacks a lot of features, many features are implemented differently
and they requires modifications of xsl stylesheets (or fix in passivetex - I
have chosen to fix xsl-stylesheets as those are easier to understand for me )
and in fact upstream is dead and there are more options for fo processing as fop
- which is now in fedora rawhide and soon will get support in xmlto. 
Comment 12 W. Michael Petullo 2007-12-17 05:33:41 EST
Okay, rpm -e docbook-style-xsl followed by rpm -Uvh docbook-style-xsl seems to
fix this latest problem. Everything worked fine once I got past the problem
documented in comment #8.

Confirmed fixed in docbook-style-xsl-1.73.2-9.fc9.

Note You need to log in before you can comment on or make changes to this bug.