Bug 36664 - Core dump or zombie created when loading XIM server
Summary: Core dump or zombie created when loading XIM server
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-19 15:17 UTC by Xianglei Zhu
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-21 08:23:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Xianglei Zhu 2001-04-19 15:17:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3 i686)


When I login in graphical mode as a normal user, there is a core in my home
directory.
When I login in as root, there is a zombie process [true <*>] which can be
seen with "ps aux". 

Reproducible: Always
Steps to Reproduce:
1.login firstly as normal user,there is a core.delete it.logout
2.login as root ,there is zombie,logout
3.login as normal user,there is a new core
	

There is bug in /etc/X11/xinit/xinitrc.d/xinput,
It's very easy to fix it.
Just add one line to the beginning of the file (after #!/bin/sh of course):
XIM_ARGS=""
Ok, everything is well now.

Comment 1 Mike A. Harris 2001-04-19 19:31:21 UTC
Than, could you look at this, and recommend whether this is the proper fix,
or if something else should be changed instead?

Comment 2 Xianglei Zhu 2001-04-20 01:29:20 UTC
I can't find the bug now, even if I remove the line added to xinput. 
I don't know the reason for this, but this bug did happen every time before I
make this change. 
The variable XIM_ARGS is not defined when it is used in xinput by default.  Is
it reasonable?
Sorry, I'm not good at shell programming.

Comment 3 Ngo Than 2001-04-20 12:38:10 UTC
This problem does not appear on my machine. on my mchine the LANG=de_DE

Which LANG is set on your machine?



Comment 4 Xianglei Zhu 2001-04-21 08:22:41 UTC
When I finished installing Redhat 7.1 and restarted to login as a normal user in
graphics mode first time, this bug occured. The LANG is en_US. But now the bug 
can't be reproduced on my machine even I remove the line 'XIM_ARGS=""' from
xinput.

Comment 5 Mike A. Harris 2001-05-15 10:42:58 UTC
I can't reproduce it either.


Note You need to log in before you can comment on or make changes to this bug.