Bug 36692 - WINGs headers not found
Summary: WINGs headers not found
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-19 21:18 UTC by Johannes Eriksson
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 22:13:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WINGs/WINGs/Makefile.am (174 bytes, text/plain)
2001-08-28 02:52 UTC, Crutcher Dunnavant
no flags Details

Description Johannes Eriksson 2001-04-19 21:18:13 UTC
It seems like the WINGs header files (WINGs.h, WINGsP.h, WUtil.h) are
assumed to be in a subdirectory (/usr/include/WINGs/). The
WindowMaker-libs-0.64.0-2 rpm extracts them into /usr/include so building
WINGs applications fails (because WINGs.h tries to #include
<WINGs/WUtil.h>). Fixed it temporarily by symlinking /usr/include/WINGs
back to /usr/include.

Comment 1 Crutcher Dunnavant 2001-06-25 22:13:41 UTC
I need to figure out the fix here.

Comment 2 Crutcher Dunnavant 2001-08-28 02:51:33 UTC
GARH! Automake issues. The fix is:

use the following file as WINGs/WINGs/Makefile.am, and rerun automake, and then
configure.

fixed in rawhide.

Comment 3 Crutcher Dunnavant 2001-08-28 02:52:35 UTC
Created attachment 29814 [details]
WINGs/WINGs/Makefile.am


Note You need to log in before you can comment on or make changes to this bug.