Bug 36695 - bad lilo.conf after upgrade
Summary: bad lilo.conf after upgrade
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-19 22:00 UTC by mw
Modified: 2007-03-27 03:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-09 19:15:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mw 2001-04-19 22:00:03 UTC
After upgrade (from wolverine to 7.1, but I saw the same from 7.0 to
wolverine), I am left with a syntactically incorrect lilo.conf.

Original lilo.conf
=============

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
default=linux

image=/boot/vmlinuz
        label=linux
        read-only
        root=/dev/hda1

But after installtion, I had

# cat /etc/lilo.conf
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
default
linear

image=/boot/vmlinuz
        label=linux
        read-only
        root=/dev/hda1

image=/boot/vmlinuz-2.4.2-2
        label
        read-only
        root=/dev/hda1

The error is in the stale `default' and `label', I believe.

Comment 1 Brent Fox 2001-04-26 19:54:57 UTC
Did you modify the label in the LILO configuration screen?

Comment 2 mw 2001-05-01 17:58:22 UTC
Nope. I am not even sure I got a lilo configuration screen.  The reason I know I
did not modify it even if I had one is because I always test the first upgrade
by not changing anything (including the list of upgradable packages).

Comment 3 Brent Fox 2001-05-01 19:34:56 UTC
We have not seen this in our internal testing.  Was the system bootable after
the upgrade?

Comment 4 mw 2001-05-03 16:09:19 UTC
Nope.  But luckily I had my 7.0 bootfloppy, so I could fix lilo.conf.



Comment 5 Brent Fox 2001-05-09 19:15:09 UTC
I can't explain why that happened.  We have not seen this in our internal
testing.  I just tried this on my test machine and things worked fine.


Note You need to log in before you can comment on or make changes to this bug.