Bug 367101 - document parted resize limitations in man page
document parted resize limitations in man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: parted (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
: 429326 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 12:05 EST by Bryn M. Reeves
Modified: 2010-10-22 16:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0322
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2007-11-05 12:05:10 EST
Description of problem:
This request is split off from bug 252414 (parted: unable to resize partition
and its filesystem).

Partner would like the following text (or similar) added to the parted man page
to document the current behavior of the resize command:

"Partition and filesystem resizing for ext2/ext3 in parted does not work as well
as using resize2fs(8) to shrink the filesystem and a tool like fdisk to redefine
the boundaries."

Version-Release number of selected component (if applicable):
parted-1.8.1-12.el5

How reproducible:
100%

Steps to Reproduce:
1. man parted
  
Actual results:
No mention of limitations on the current implementation.

Expected results:
Limitations in the current resize implementation are documented.
Comment 1 RHEL Product and Program Management 2007-11-05 12:14:50 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 David Cantrell 2007-12-13 23:06:57 EST
Fixed in parted-1.8.1-13.el5, moving to MODIFIED.
Comment 7 errata-xmlrpc 2008-05-21 12:56:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0322.html
Comment 9 Joel Andres Granados 2008-06-10 12:15:07 EDT
*** Bug 429326 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.