Bug 367351 - /sys contains a file name with \000 as the first character
/sys contains a file name with \000 as the first character
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 404251 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 14:57 EST by Lubomir Kundrak
Modified: 2007-12-05 15:44 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.8-63
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 15:44:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-11-05 14:57:01 EST
Description of problem:

[lkundrak@pluto ~]$ ls -la /sys/module/nousb/parameters
total 0
drwxr-xr-x 2 root root 0 2007-11-05 15:43 
drwxr-xr-x 2 root root 0 2007-11-05 15:43 .
drwxr-xr-x 3 root root 0 2007-11-05 15:43 ..
[lkundrak@pluto ~]$

Please notice the file with name ""

[lkundrak@pluto ~]$ cd /sys/module/nousb/parameters
[lkundrak@pluto parameters]$ ls -la
ls: cannot access : No such file or directory
total 0
-????????? ? ?    ?    ?                ? 
drwxr-xr-x 2 root root 0 2007-11-05 15:43 .
drwxr-xr-x 3 root root 0 2007-11-05 15:43 ..
[lkundrak@pluto parameters]$ 

No idea why is this different

Version-Release number of selected component (if applicable):

kernel-2.6.23.1-42.fc8

How reproducible:

Seems reproducible on just one machine. I'll try not to reboot it.
Comment 2 Chuck Ebbert 2007-11-05 15:33:56 EST
Patch is already queued to fix this, it is upstream commit
faf8c714f4508207a9c81cc94dafc76ed6680b44.
Comment 3 Chuck Ebbert 2007-11-29 09:48:12 EST
*** Bug 404251 has been marked as a duplicate of this bug. ***
Comment 4 Chuck Ebbert 2007-11-29 09:52:58 EST
In 2.6.23.8-63

Note You need to log in before you can comment on or make changes to this bug.