Bug 367521 - system-config-network in FC8 RC3 will not start,after 5 Minutes the messages :
system-config-network in FC8 RC3 will not start,after 5 Minutes the messages :
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 382681 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 16:36 EST by Bernd Eckstein
Modified: 2008-02-01 07:53 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.4.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 07:53:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Eckstein 2007-11-05 16:36:36 EST
Component: system-config-network
Version: 1.4.3
Summary: TB5b2f4f9d genClass.py:187:_objToStr:MemoryError

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
278, in load
    self.loadProfiles()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
294, in loadProfiles
    profilelist = getProfileList()
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 652,
in getProfileList
    __PFList.load()
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 94,
in load
    log.log(5, "ActiveProfile: %s" % str(prof))
  File "/usr/share/system-config-network/netconfpkg/genClass.py", line 399, in
__str__
    return GenClass.__str__(self)
  File "/usr/share/system-config-network/netconfpkg/genClass.py", line 174, in
__str__
    return self._objToStr(parentStr)
  File "/usr/share/system-config-network/netconfpkg/genClass.py", line 219, in
_objToStr
    retstr += val._objToStr("%s.%s" % (parentStr, child))
  File "/usr/share/system-config-network/netconfpkg/genClass.py", line 187, in
_objToStr
    retstr += child._objToStr("%s.%d" % (parentStr, num))
MemoryError

Local variables in innermost frame:
attr: {'FLAGS': [], 'TYPE': 'LIST', 'NAME': 'Host'}
Comment 1 Harald Hoyer 2007-11-06 02:36:13 EST
MemoryError

Hmm, do you have a 3GB /etc/hosts file or something?
Comment 2 Satish Balay 2007-11-08 00:16:53 EST
Reg: system-config-network-1.4.3-1.fc8

perhaps this is the same issue I'm encountering..

system-config-network basically rewrites bloated /etc/hosts causing subsequent
reads by iteslf hang..

For eg: it modifiles the following file

>>>>>>>>>
[root@asterix etc]# cat /etc/hosts
127.0.0.1 localhost
127.0.0.1 localhost.localdomain
[root@asterix etc]# neat    # <<<< quit/save when the gui pops up >>>>>
[root@asterix etc]# cat /etc/hosts
127.0.0.1       localhost       localhost.localdomain
127.0.0.1       localhost       localhost.localdomain

<<<<<<<<

Notice the following negatives:

-- For one it reformats [messing the original format, comments]
-- It also is creating dupliate entries thus bloating the /etc/hosts file.

I've been using http://everythingisnt.com/hosts for adblocking. This file is
about 44K. When system-config-network is done processing it - it becomes
unreadable - and expands to 32M

>>>>>>>
[root@asterix etc]# du -sh /etc/hosts
44K     /etc/hosts
[root@asterix etc]# neat
[root@asterix etc]# du -sh /etc/hosts
32M     /etc/hosts
[root@asterix etc]# 
<<<<<<<<<<


I had no such problems with FC6.

[Another annoying thing about this tool is: If I save and quit - it prompts to
save again]
Comment 3 Satish Balay 2007-11-13 10:38:08 EST
Update:

I've just installed system-config-network-1.4.5-1.fc8 [from updates-testing].
Looks like the annoying prompt to 'save' at quit [when no changes were made] is
fixed now.

However the primary issue of this bugzilla [i.e /etc/hosts gets modified with
dupliate  entries] still exists.
Comment 4 Jiri Moskovcak 2007-11-14 11:47:37 EST
*** Bug 382681 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.