Bug 367971 - mock fails due using "useradd -n"
mock fails due using "useradd -n"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 03:09 EST by Ralf Corsepius
Modified: 2013-01-09 20:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 11:35:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2007-11-06 03:09:41 EST
Description of problem:

Mock internally uses "/usr/sbin/useradd -n" to setup its accounts on guest systems.

"-n" is a redhat proprietary addition to useradd, i.e. non-portable and likely
non-available on guest systems.

Version-Release number of selected component (if applicable):
mock-0.8.4-2.fc7

How reproducible:
Deterministic

Steps to Reproduce:
1. Set up a mock *cfg for non-redhat systems.
2. mock init fails.
 

Expected results:
Function.

Additional info:
This bug is a return of an old bug which previously had affected early versions
of mock, but had not been present for quite a while (mock-0.6.x).

It renders fedora and mock unusable as host platform/build environment for
building rpms for "other distros".
Comment 1 Michael E Brown 2007-11-06 11:35:38 EST
Fixed in mock 0.8.5. There is a 'useradd' config option to set the path and args
to useradd. Please note that the format of this option has changed since 0.7, so
config sharing between old and new versions will not work.
Comment 2 Ralf Corsepius 2007-11-06 11:50:34 EST
It still seems to have escaped to you that the upgrade to mock-0.8.x also broken
all customized *.cfg's, broke all build-scripts using caches, and leaves caches
laying around on FC7.

IMNSHO, this upgrade should not have been performed, due all the ABI breakages
it implies. So far all these changes, oversights and bugs have cost me at least
2 days without having been able to resurrect my local buildsystem yet.
Comment 3 Ralf Corsepius 2007-11-06 11:55:20 EST
Where's the rpm? I can't find it, neither in bodhi nor in updates.

Note You need to log in before you can comment on or make changes to this bug.